Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 2043124

Summary: Import a template that has multiple copied fails after it's removed from the system
Product: [oVirt] ovirt-engine Reporter: Benny Zlotnik <bzlotnik>
Component: BLL.StorageAssignee: Benny Zlotnik <bzlotnik>
Status: CLOSED CURRENTRELEASE QA Contact: Ilia Markelov <imarkelo>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.4.10CC: ahadas, bugs, eshames
Target Milestone: ovirt-4.5.0Flags: ahadas: ovirt-4.5?
Target Release: 4.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ovirt-engine-4.5.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-04-20 06:33:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Storage RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Benny Zlotnik 2022-01-20 16:43:53 UTC
Description of problem:
Import a template that has copies on multiple storage domains, after it is removed from the system would fail. This happens because OVF entry has references to other storage domains and engine tries to fetch information about the template's images on storage domains where they no longer exist


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a template and copy it to multiple storage domains
2. Detach one of the storage domains
3. Remove the template from the system
4. Try to import the template from the reattached storage domain

Actual results:
Fails

Expected results:
Succeeds

Additional info:

Comment 3 Ilia Markelov 2022-03-23 09:23:47 UTC
Verified

Succeeded to import the template from the reattached storage domain.

vdsm-4.50.0.10-1.el8ev.x86_64

Version 4.5.0.1-601.f26e9ea8cac5.3.el8ev

Comment 4 Sandro Bonazzola 2022-04-20 06:33:59 UTC
This bugzilla is included in oVirt 4.5.0 release, published on April 20th 2022.

Since the problem described in this bug report should be resolved in oVirt 4.5.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.