Bug 2043318 - fcitx-qt5 is not installable in RHEL 8
Summary: fcitx-qt5 is not installable in RHEL 8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: fcitx-qt5
Version: epel8
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Qiyu Yan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-21 01:22 UTC by Gris Ge
Modified: 2022-01-29 06:42 UTC (History)
3 users (show)

Fixed In Version: fcitx-qt5-1.2.4-4.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-29 06:42:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Gris Ge 2022-01-21 01:22:15 UTC
Description of problem:

With RHEL 8.5, `dnf install fcitx-qt5` will fail with error:

Error:
 Problem: problem with installed package qt5ct-1.1-6.el8.x86_64
  - package qt5ct-1.1-6.el8.x86_64 requires qt5-qtbase(x86-64) = 5.15.2, but none of the providers can be installed
  - package qt5ct-1.1-6.el8.x86_64 requires libQt5Core.so.5(Qt_5.15)(64bit), but none of the providers can be installed
  - package fcitx-qt5-1.2.4-3.el8.x86_64 requires qt5-qtbase(x86-64) = 5.11.1, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.15.2-3.el8.x86_64 and qt5-qtbase-5.11.1-5.el8.x86_64
  - cannot install both qt5-qtbase-5.15.2-3.el8.x86_64 and qt5-qtbase-5.11.1-7.el8.x86_64
  - conflicting requests
  - cannot install both qt5-qtbase-5.11.1-5.el8.x86_64 and qt5-qtbase-5.15.2-3.el8.x86_64
  - cannot install both qt5-qtbase-5.11.1-7.el8.x86_64 and qt5-qtbase-5.15.2-3.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Version-Release number of selected component (if applicable):
fcitx-qt5-1.2.4-3.el8.x86_64

How reproducible:
100%

Steps to Reproduce:
1. dnf install fcitx-qt5 qt5ct
2.
3.

Actual results:

Not installable

Expected results:

Installable

Additional info:

A simple recompile in koji could fix the problem.

Comment 1 Fedora Update System 2022-01-21 07:02:12 UTC
FEDORA-EPEL-2022-64dc24f255 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-64dc24f255

Comment 2 Fedora Update System 2022-01-22 01:40:21 UTC
FEDORA-EPEL-2022-64dc24f255 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-64dc24f255

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2022-01-29 06:42:39 UTC
FEDORA-EPEL-2022-64dc24f255 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.