Bug 204338 - initrd images unowned
initrd images unowned
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-28 12:16 EDT by Thomas Woerner
Modified: 2015-01-04 17:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 17:07:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Woerner 2006-08-28 12:16:29 EDT
Description of problem:
initrd images in /boot do not belong to any package, should be ghost.

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2517.fc6

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Lawrence 2006-09-05 11:17:59 EDT
Reassigning to correct owner, kernel-maint.
Comment 2 Dave Jones 2006-09-16 23:30:14 EDT
Fixed in cvs, will be in next rawhide.
Comment 3 Dave Jones 2006-09-17 11:40:49 EDT
Adding %ghost /boot/initrd-%{KVERREL}.img to the %files sections caused build
errors (Can't find file -- which is understandable, as it's not there during the
build process, it gets created at %install time).

How should this be fixed?
Comment 4 Thomas Woerner 2006-09-18 08:00:47 EDT
I'd suggest this here:

%ghost %config(missingok) %verify(not size md5 mtime) /boot/initrd-%{KVERREL}.img

I have noticed that the kernel images are mode "-rw-r--r--", but the initrd
images are "-rw-------". This is strange.

Maybe changing the mode for all to "-rw-------" or "-rw-r--r--"?
Comment 5 Thomas Woerner 2006-09-18 08:09:41 EDT
Just touch the ghost file in install, it will not get appended to the rpm.
Comment 7 Jarod Wilson 2006-09-22 09:46:28 EDT
This does the trick for me. Since initrd's are created and destroyed in 
scriptlets, I don't think marking them as %config is worthwhile, not sure about
 %verify.

# rpm -qf /boot/initrd-2.6.18-1.2686.fc6.img
kernel-2.6.18-1.2686.fc6

cvs diff: Diffing .
Index: kernel-2.6.spec
===================================================================
RCS file: /cvs/dist/rpms/kernel/devel/kernel-2.6.spec,v
retrieving revision 1.2686
diff -u -r1.2686 kernel-2.6.spec
--- kernel-2.6.spec     21 Sep 2006 19:10:05 -0000      1.2686
+++ kernel-2.6.spec     22 Sep 2006 13:42:35 -0000
@@ -1249,6 +1249,7 @@
     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
+    touch $RPM_BUILD_ROOT/boot/initrd-$KernelVer.img
     cp $KernelImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
     if [ -f arch/$Arch/boot/zImage.stub ]; then
       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/
zImage.stub-$KernelVer || :
@@ -1766,7 +1767,7 @@
 /lib/modules/%{KVERREL}/extra
 /lib/modules/%{KVERREL}/updates
 /lib/modules/%{KVERREL}/weak-updates
-#%ghost /boot/initrd-%{KVERREL}.img
+%ghost /boot/initrd-%{KVERREL}.img

 %files devel
 %defattr(-,root,root)
@@ -1795,7 +1796,7 @@
 /lib/modules/%{KVERREL}PAE/extra
 /lib/modules/%{KVERREL}PAE/updates
 /lib/modules/%{KVERREL}PAE/weak-updates
-#%ghost /boot/initrd-%{KVERREL}PAE.img
+%ghost /boot/initrd-%{KVERREL}PAE.img

 %files PAE-devel
 %defattr(-,root,root)
@@ -1819,7 +1820,7 @@
 /lib/modules/%{KVERREL}smp/extra
 /lib/modules/%{KVERREL}smp/updates
 /lib/modules/%{KVERREL}smp/weak-updates
-#%ghost /boot/initrd-%{KVERREL}smp.img
+%ghost /boot/initrd-%{KVERREL}smp.img

 %files smp-devel
 %defattr(-,root,root)
@@ -1847,7 +1848,7 @@
 /lib/modules/%{KVERREL}xen/extra
 /lib/modules/%{KVERREL}xen/updates
 /lib/modules/%{KVERREL}xen/weak-updates
-#%ghost /boot/initrd-%{KVERREL}xen.img
+%ghost /boot/initrd-%{KVERREL}xen.img

 %files xen-devel
 %defattr(-,root,root)
@@ -1874,7 +1875,7 @@
 /lib/modules/%{KVERREL}kdump/extra
 /lib/modules/%{KVERREL}kdump/updates
 /lib/modules/%{KVERREL}kdump/weak-updates
-#%ghost /boot/initrd-%{KVERREL}kdump.img
+%ghost /boot/initrd-%{KVERREL}kdump.img

 %files kdump-devel
 %defattr(-,root,root)
Comment 8 Jarod Wilson 2006-09-25 17:07:23 EDT
Changes to make initrd images owned by kernel rpms committed, should show up in
a rawhide sometime soon.

Note You need to log in before you can comment on or make changes to this bug.