Bug 2043411 (CVE-2021-40691) - CVE-2021-40691 moodle: Session Hijack risk when Shibboleth authentication is enabled
Summary: CVE-2021-40691 moodle: Session Hijack risk when Shibboleth authentication is ...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2021-40691
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2043413 2043412
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-21 08:33 UTC by Dhananjay Arunesh
Modified: 2022-01-21 09:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-21 09:30:38 UTC


Attachments (Terms of Use)

Description Dhananjay Arunesh 2022-01-21 08:33:17 UTC
A session hijack risk was identified in the Shibboleth authentication plugin.

References:
https://moodle.org/mod/forum/discuss.php?d=427103

Comment 1 Dhananjay Arunesh 2022-01-21 08:33:36 UTC
Created moodle tracking bugs for this issue:

Affects: epel-7 [bug 2043413]
Affects: fedora-all [bug 2043412]

Comment 2 Product Security DevOps Team 2022-01-21 09:30:37 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.