This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 204383 - We allow comparing files to directories
We allow comparing files to directories
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn420
All Linux
medium Severity medium
: ---
: ---
Assigned To: Grant Gainey
wes hayutin
:
Depends On:
Blocks: rhn500h-config-mgmt
  Show dependency treegraph
 
Reported: 2006-08-28 15:46 EDT by Ken Ganong
Modified: 2007-04-18 13:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn500h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 22:57:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ken Ganong 2006-08-28 15:46:18 EDT
Currently, in the file compare list displays, it shows directories as well as files.
Currently, the file compare page shows a diff between a file and directory.

This diff is extremely pointless because directories have no content.  You
should not be able to try and diff a file and a directory.
The only things that can change between revisions of a directory are the file
mode, user, and group.
Comment 1 Ken Ganong 2006-08-31 08:52:08 EDT
Now you can diff any two files,
but the content diff only shows for two text files.
Meta-data, like the file type, file mode, etc. is diffed no matter what two
files you select.
Comment 2 Ken Ganong 2006-10-09 16:07:00 EDT
Changing status to modified for a bunch of my bugs.
Comment 3 Ken Ganong 2006-11-13 12:19:34 EST
Moving bugs to ON_DEV
Comment 4 Ken Ganong 2006-12-05 09:58:04 EST
Moving my bugs to ON_QA
Comment 5 Ken Ganong 2006-12-15 15:59:31 EST
Passing on my config management bugs to ggainey
Comment 6 wes hayutin 2007-01-08 10:24:50 EST
This looks good.. 
Files w/ different directory structures.
The directories differences are not being diffed, which is the correct behavior.
Comment 7 Brandon Perkins 2007-03-12 22:57:09 EDT
Closed in the rhn500h Release.

Note You need to log in before you can comment on or make changes to this bug.