Bug 204403 - Inkboard feature disabled
Inkboard feature disabled
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-08-28 17:06 EDT by Eric Tanguy
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-02-08 17:49:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eric Tanguy 2006-08-28 17:06:04 EDT
Description of problem:
as said in the spec file : 
Inkboard feature disabled pending further security tests since Jun 28 2006.
What's the status of the security tests ? When this feature will be enabled ?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:
Inkboard feature enabled

Additional info:
Comment 1 Denis Leroy 2006-08-28 17:15:00 EDT
Good question ;-)

Do you know if it actually works ? Last time i tried it, it would crash in the
loudmouth library, but that was a while ago. 

I'll aks the question upstream.
Comment 2 Eric Tanguy 2006-08-29 01:28:37 EDT
I didn't try it since a while but i would like to test it and see how it is
improved ...
Comment 3 Denis Leroy 2006-08-29 14:16:44 EDT
Discussion is ongoing at


It probably won't be enabled before the 0.44.1 release.
Comment 4 Eric Tanguy 2006-09-08 14:43:00 EDT
And now that 0.44.1 release is available in extras, inkboard could be enabled ?
Comment 5 Denis Leroy 2006-09-09 05:35:35 EDT
Upstream still doesn't enable it by default... If you have some time, I would
love to hear some feedback on its stability (you can compile it from the SRPM
with rpmbuild --with inkboard). I know one of the problems is that it will only
work with specific Jabber servers...
Comment 6 Jeff Moe (jebba) 2007-01-07 01:19:06 EST
I have used a --with inkboard build of this and version 0.44.1.

I tested it with two other users (individually) using the same build and the
jabber.org server. We pretty much just "tooled around" for a bit... It was
surprisingly responsive. Pasting .svgs worked and appeared on the other end. It
never crashed. I can't make any comments on how secure it is though. I can say
it works and it's cool though. :)
Comment 7 Denis Leroy 2007-01-07 07:09:13 EST
Thanks for the investigation. 0.45 is just around the corner, so it sounds
reasonable to enable the feature then.
Comment 8 Eric Tanguy 2007-02-05 16:15:19 EST
0.45 is now out...
Comment 9 Denis Leroy 2007-02-05 18:31:12 EST
I know i know, a RL emergency kicked in and delayed my packaging work. I have a
pre1 src.rpm on www.pooloshark.org/inkscape/ if anyone has spare cycles to do
some preliminary testing, the spec should "just work" with 0.45...

I still have doubts whether inkboard is mature enough for inclusion, a feeling
that is shared by most of the upstream folks (the GUI is also not intuitive),
but on the other hand it won't improve if nobody uses it...
Comment 10 Denis Leroy 2007-02-08 17:49:42 EST

Note You need to log in before you can comment on or make changes to this bug.