Bug 204408 - Latest autofs update breaks nis automounts
Latest autofs update breaks nis automounts
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-28 17:35 EDT by Xixi
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 09:56:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 7 Jeffrey Moyer 2006-09-07 14:19:47 EDT
Previously, autofs would only convert maps of the names "auto_home" and
"auto_mnt" to auto.home and auto.mnt.  A bug was filed about this, and the
behaviour has changed as a result.  The original intent was to convert all
underscores to dots.

Based on the limited information in this bugzilla, it really looks like the
customer should have UNDERSCORETODOT set to 0.
Comment 9 Jeffrey Moyer 2006-09-12 09:04:13 EDT
I'm still waiting for feedback on this.
Comment 10 Brandon Kitchen 2006-09-12 09:35:08 EDT
My auto.master was as follows before the latest autofs update and clients were
getting the maps from NIS fine:

/remnet /etc/auto.remote -bg,intr,rw
/homenet  /etc/auto.homes  -bg,intr,rw
/proj /etc/auto.project -bg,intr,rw
/apps /etc/auto.apps -bg,intr,rw
/opt/media  /etc/auto.media --timeout=10 -fstype=auto,loop,user,owner

After the latest autofs update, the clients started complaining that they could
not find the NIS maps and stopped working.

I changed my auto.master as follows to get it to work with the latest autofs update:

/remnet auto.remote -bg,intr,rw
/homenet  auto.homes  -bg,intr,rw
/proj auto.project -bg,intr,rw
/apps auto.apps -bg,intr,rw
/opt/media  auto.media --timeout=10 -fstype=auto,loop,user,owner




Note You need to log in before you can comment on or make changes to this bug.