Bug 204429 - mock rh9 builds fail due to missing buildsys packages
mock rh9 builds fail due to missing buildsys packages
Status: CLOSED NOTABUG
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Clark Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-28 20:56 EDT by Travers Carter
Modified: 2013-01-09 23:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 14:30:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Travers Carter 2006-08-28 20:56:05 EDT
Description of problem:
mock builds using redhat-9-i386 fail due to missing buildsys-* packages at
http://fedoraproject.org/buildgroups/rh9/i386/

Version-Release number of selected component (if applicable):
0.6-4.fc5

How reproducible:
Always

Steps to Reproduce:
1. mock --debug -r redhat-9-i386 <srcrpm>
  
Actual results:
...
mount: according to mtab, devpts is already mounted on
/var/lib/mock/redhat-9-i386/root/dev/pts
DEBUG: yum: command /usr/sbin/mock-helper yum --installroot
/var/lib/mock/redhat-9-i386/root install buildsys-build
DEBUG: Executing /usr/sbin/mock-helper yum --installroot
/var/lib/mock/redhat-9-i386/root install buildsys-build
No Match for argument: buildsys-build
Could not find useradd in chroot, maybe the install failed?
ending
DEBUG: Executing /usr/sbin/mock-helper umount /var/lib/mock/redhat-9-i386/root/proc
DEBUG: Executing /usr/sbin/mock-helper umount
/var/lib/mock/redhat-9-i386/root/dev/pts
done


Expected results:

Additional info:
Comment 1 Clark Williams 2006-08-29 14:30:15 EDT
I don't think the legacy guys are putting out buildsys-build rpms for the RHL
builds. That's why we included the buildsys-build.spec file in the binary RPM
for mock, so that folks can create their own. 

Check the spec file at: /usr/share/doc/mock-<version>/buildsys-build.spec

Note You need to log in before you can comment on or make changes to this bug.