Bug 2044422 - SELinux is preventing evince-thumbnai from 'write' accesses on the sock_file bus.
Summary: SELinux is preventing evince-thumbnai from 'write' accesses on the sock_file ...
Keywords:
Status: CLOSED DUPLICATE of bug 2042696
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 35
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:185f645b9e7f336395b35b7ebc1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-24 15:16 UTC by Sergei S. Rublёv
Modified: 2022-01-26 14:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-26 14:10:38 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Sergei S. Rublёv 2022-01-24 15:16:28 UTC
Description of problem:
Browsing directories with Fedora-LXQt spin using its default PCmanFM-Qt file manager
SELinux is preventing evince-thumbnai from 'write' accesses on the sock_file bus.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that evince-thumbnai should be allowed write access on the bus sock_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'evince-thumbnai' --raw | audit2allow -M my-evincethumbnai
# semodule -X 300 -i my-evincethumbnai.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:session_dbusd_tmp_t:s0
Target Objects                bus [ sock_file ]
Source                        evince-thumbnai
Source Path                   evince-thumbnai
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-35.11-1.fc35.noarch
Local Policy RPM              selinux-policy-targeted-35.11-1.fc35.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.15.14-200.fc35.x86_64 #1 SMP Tue
                              Jan 11 16:49:27 UTC 2022 x86_64 x86_64
Alert Count                   24
First Seen                    2022-01-24 16:01:42 MSK
Last Seen                     2022-01-24 18:12:52 MSK
Local ID                      ea8a7987-bca0-446a-9a66-3325606f34f7

Raw Audit Messages
type=AVC msg=audit(1643037172.958:1109): avc:  denied  { write } for  pid=73849 comm="totem-video-thu" name="bus" dev="tmpfs" ino=88 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:session_dbusd_tmp_t:s0 tclass=sock_file permissive=0


Hash: evince-thumbnai,thumb_t,session_dbusd_tmp_t,sock_file,write

Version-Release number of selected component:
selinux-policy-targeted-35.11-1.fc35.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.15.2
hashmarkername: setroubleshoot
kernel:         5.15.14-200.fc35.x86_64
type:           libreport

Comment 1 Zdenek Pytela 2022-01-26 14:10:38 UTC

*** This bug has been marked as a duplicate of bug 2042696 ***


Note You need to log in before you can comment on or make changes to this bug.