Bug 204447 - Xclients.d files not sourced by Xclients script
Summary: Xclients.d files not sourced by Xclients script
Status: CLOSED DUPLICATE of bug 204446
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-xinit   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-29 06:14 UTC by Eric Moret
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 06:15:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Moret 2006-08-29 06:14:13 UTC
Description of problem:

I am trying to launch matchbox-window-manager (alien rpm) from /usr/bin/startx 
and found out about the new Xclients.d facility described in #142260. Looking 
around a bit I can't seem to find a way to get this facility working with 
startx. The default /etc/X11/xinit/Xclients script does not source 
my /etc/X11/xinit/Xclients.d/Xclients.mb.sh like /etc/X11/xinit/Xsession 
does.

Version-Release number of selected component (if applicable):
xorg-x11-xinit-1.0.2-9.fc6

How reproducible:
Always

Steps to Reproduce:
1. Make sure you do not have any window manager or desktop installed.
2. install matchbox-window-manager
3. create a window manager startup script in /etc/X11/xinit/Xclients.d 
# cat > /etc/X11/xinit/Xclients.d/Xclients.mb.sh
/usr/bin/xterm &
exec /usr/bin/matchbox-window-manager
^D
3. start x window with startx
# startx
  
Actual results:
X does not start

Expected results:
X starts and launches an xterm and the matchbox window manager

Comment 1 Eric Moret 2006-08-29 06:15:30 UTC

*** This bug has been marked as a duplicate of 204446 ***


Note You need to log in before you can comment on or make changes to this bug.