Bug 204451 - [mail][text] Printing failed for i18n text
[mail][text] Printing failed for i18n text
Status: CLOSED DUPLICATE of bug 202751
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-29 03:03 EDT by A S Alam
Modified: 2013-07-02 20:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-12 03:20:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
i18n text body, when evolution started in en_US locale (42.28 KB, application/postscript)
2006-08-29 03:03 EDT, A S Alam
no flags Details

  None (edit)
Description A S Alam 2006-08-29 03:03:56 EDT
Description of problem:
for Printing a mail is in i18n Text Format is not print Body of message, but
working fine for English Text.

Version-Release number of selected component (if applicable):
evolution-2.7.92-4.fc6

How reproducible:
Everytime during starting Evolution

Steps to Reproduce:
1. start Evoution (in en_US.UTF-8 also)
2. New Mail
3. Type something i18n text in Body (text format)

  
Actual results:
i18n Text is not printed in Body, but in From/To/Subject is ok

Expected results:
text should be printed

Additional info:
1) PS file has also have same problem
2) save as draft and then print without opening in composer is ok
Comment 1 A S Alam 2006-08-29 03:03:58 EDT
Created attachment 135107 [details]
i18n text body, when evolution started in en_US locale
Comment 2 Leon Ho 2006-09-05 01:36:01 EDT
What's the difference between this and bug #196110?
Comment 3 A S Alam 2006-09-05 01:44:54 EDT
Nothing is printed in body instead of Junk or # characters as in bug 196110. It
is true to for CJK/Indic Languages
Comment 4 Mayank Jain 2006-09-11 07:14:59 EDT
Initial investigation...

$evo/plugins/print-message/print-message.c : org_gnome_print_message
 --> data->msg = e_msg_composer_get_message (composer, 1);

$evo/composer/e-msg-composer.c : e_msg_composer_get_message (EMsgComposer
*composer, gboolean save_html_object_data)
 --> return build_message (composer, save_html_object_data);

$evo/composer/e-msg-composer.c : build_message (EMsgComposer *composer, gboolean
save_html_object_data)
 --> if (p->mime_body) {
Comment 5 Mayank Jain 2006-09-12 03:20:38 EDT

*** This bug has been marked as a duplicate of 202751 ***

Note You need to log in before you can comment on or make changes to this bug.