Bug 204457 - sysreport fails copying chroot'ed proc/ directory
sysreport fails copying chroot'ed proc/ directory
Status: CLOSED DUPLICATE of bug 201835
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sysreport (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: Reopened
Depends On: 201835
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-29 05:55 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 06:32:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport-no-chrooted-proc.patch (347 bytes, patch)
2006-08-29 05:55 EDT, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2006-08-29 05:55:12 EDT
sysreport-1.3.15-5
bind-9.2.4-16.EL4
bind-chroot-9.2.4-16.EL4
caching-nameserver-7.3-3

1. Install sysreport as well as a chroot'ed caching nameserver
2. Start named
3. Check that /var/named/chroot/proc is mounted
4. Launch a sysreport

Getting information from /var/named will hang, as sysreport tries to copy data
from /var/named/chroot/proc (kmsg most likely).

The attached patch makes sysreport avoid trying to copy the chroot'ed proc/
altogether, as it would duplicate information from the root /proc.
Comment 1 Bastien Nocera 2006-08-29 05:55:13 EDT
Created attachment 135114 [details]
sysreport-no-chrooted-proc.patch
Comment 2 Ngo Than 2006-08-29 06:10:55 EDT

*** This bug has been marked as a duplicate of 201835 ***
Comment 8 Ngo Than 2006-12-06 06:32:51 EST

*** This bug has been marked as a duplicate of 201835 ***

Note You need to log in before you can comment on or make changes to this bug.