Bug 2044622 - Kube-Scheduler revision-pruner fail during install of new cluster
Summary: Kube-Scheduler revision-pruner fail during install of new cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-scheduler
Version: 4.9
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.9.z
Assignee: Jan Chaloupka
QA Contact: RamaKasturi
URL:
Whiteboard:
: 2065312 (view as bug list)
Depends On: 2026352
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-24 20:22 UTC by OpenShift BugZilla Robot
Modified: 2022-03-29 15:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-14 12:00:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-apiserver-operator pull 1297 0 None open bug 2044622: Pruner check if dir exists 4.9 2022-02-02 09:26:28 UTC
Github openshift cluster-kube-controller-manager-operator pull 593 0 None Merged bug 2044622: Sync with the latest 4.9 library-go 2022-01-25 18:12:13 UTC
Github openshift cluster-kube-scheduler-operator pull 405 0 None Merged bug 2044622: Sync with the latest 4.9 library-go 2022-01-25 21:13:40 UTC
Github openshift library-go pull 1296 0 None Merged [release-4.9] bug 2044622: staticpod pruner: check if the cert directory exists 2022-01-25 18:12:14 UTC
Red Hat Product Errata RHBA-2022:0488 0 None None None 2022-02-14 12:01:26 UTC

Comment 4 RamaKasturi 2022-02-04 06:45:04 UTC
Verified bug with the build below and i did not revision pruners failing.

[knarra@knarra ~]$ oc get clusterversion
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.9.19    True        False         11m     Cluster version is 4.9.19

[knarra@knarra ~]$ oc get pods -n openshift-kube-scheduler
NAME                                      READY   STATUS      RESTARTS   AGE
installer-3-ip-10-0-64-23                 0/1     Completed   0          25m
installer-4-ip-10-0-64-23                 0/1     Completed   0          24m
installer-5-ip-10-0-52-206                0/1     Completed   0          23m
installer-5-ip-10-0-63-232                0/1     Completed   0          22m
installer-5-ip-10-0-64-23                 0/1     Completed   0          24m
installer-6-ip-10-0-52-206                0/1     Completed   0          17m
installer-6-ip-10-0-64-23                 0/1     Completed   0          18m
installer-7-ip-10-0-52-206                0/1     Completed   0          17m
installer-7-ip-10-0-63-232                0/1     Completed   0          16m
installer-7-ip-10-0-64-23                 0/1     Completed   0          15m
openshift-kube-scheduler-ip-10-0-52-206   3/3     Running     0          17m
openshift-kube-scheduler-ip-10-0-63-232   3/3     Running     0          16m
openshift-kube-scheduler-ip-10-0-64-23    3/3     Running     0          15m
revision-pruner-7-ip-10-0-52-206          0/1     Completed   0          15m
revision-pruner-7-ip-10-0-63-232          0/1     Completed   0          15m
revision-pruner-7-ip-10-0-64-23           0/1     Completed   0          15m

Based on the above moving bug to verified state.

Comment 7 errata-xmlrpc 2022-02-14 12:00:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.21 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0488

Comment 8 Gabriel Scheffer 2022-03-29 15:38:50 UTC
*** Bug 2065312 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.