This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 204511 - Domain creation fails
Domain creation fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-29 13:31 EDT by Bill Nottingham
Modified: 2014-03-16 23:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 12:19:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-08-29 13:31:57 EDT
[root@csacca ~]# xenguest-install 
What is the name of your virtual machine? splat1
 How much RAM should be allocated (in megabytes)? 190
 What would you like to use as the disk (path)? /dev/VolGroup00/testlv
 What is the install location?
http://download.fedora.devel.redhat.com/pub/fedora/linux/core/development/x86_64/os/
 
Starting install...
libvir: Xen Daemon error : GET operation failed: No such domain splat1
libvir: Xen Daemon error : POST operation failed: No such domain splat1
Failed to get devices for domain splat1
Traceback (most recent call last):
  File "/usr/sbin/xenguest-install", line 237, in ?
    main()
  File "/usr/sbin/xenguest-install", line 229, in main
    r = guest.start_install(True)
  File "/usr/lib/python2.4/site-packages/xeninst/ParaVirtGuest.py", line 183, in
start_install
    self.domain = conn.createLinux(cxml, 0)
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 249, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed')
libvirt.libvirtError: virDomainCreateLinux() failed
[root@csacca ~]# rpm -q xen libvirt
xen-3.0.2-28
libvirt-0.1.4-4
[root@csacca ~]# uname -r
2.6.17-1.2597.fc6xen
Comment 1 Jesse Keating 2006-09-10 12:18:20 EDT
Can you dupe this anymore with recent xenguest tools?  I can't...
Comment 2 Bill Nottingham 2006-09-11 12:19:31 EDT
Yeah, appears to work.

Note You need to log in before you can comment on or make changes to this bug.