Bug 204518 - Hardware info collection tool
Hardware info collection tool
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-29 14:59 EDT by Rahul Sundaram
Modified: 2014-03-16 23:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 15:17:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2006-08-29 14:59:33 EDT
Description of problem:

We need to have a better understanding on what hardware is being used by Fedora
users and fix any issues that occur.

Actual results:

We dont have a easy to use client side tool or framework to collect all this
information

Additional info:

There are many solutions being used such as sysreport in Red Hat, hwinfo from
SUSE and https://wiki.ubuntu.com/HardwareDatabase from Ubuntu. Ubuntu has a
client side tool, GNOME and KDE frontends and infrastructure at
http://hwdb.ubuntu.com/. 

Fedora has been looking at such a tool at
http://fedoraproject.org/wiki/Infrastructure/Schedule. We need to look at
available options and pick one of them.
Comment 1 Bill Nottingham 2006-08-29 15:08:45 EDT
The implication here is that filing a bug is not the desired response to
something not working, or it is not easy enough to do so?
Comment 2 Rahul Sundaram 2006-08-29 15:13:15 EDT
Sorry. I dont understand the above response. 
Comment 3 Bill Nottingham 2006-08-29 15:25:15 EDT
When you say "We need to have a better understanding on what hardware is being
used by Fedora users and fix any issues that occur.", you are implying that
we're not getting information about hardware that isn't working. Is this because
you feel that the current mechanism (filing a bug) is not the appropriate
mechanism, or is it that filing a bug is not easy enough for users?
Comment 4 Rahul Sundaram 2006-08-29 15:35:22 EDT
Yes, Filing a bug is not easy enough and we frequently have to go back to ask
for more information(which we need to fix by installing bug buddy by default and
making sure it can work with our bugzilla). In this case, collecting all the
hardware information more proactively is quite useful. Having a nice frontend
like http://photos1.blogger.com/blogger/2710/1835/1600/hardware_database.jpg and
server side infrastructure would provide us that.  RHEL can use RHN data and
support uses sysreport for similar purposes.  See also
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=193712

It would also be a good idea to have a knowledge about what hardware is popular
to prioritise our testing and QA efforts too which Will Woods (CC'ed already) is
interested in. 

Comment 5 Mike McGrath 2006-12-20 13:48:19 EST
I've started actively working on this.  will keep you informed.
Comment 6 Bug Zapper 2008-04-03 14:03:50 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 7 Will Woods 2008-04-03 15:17:31 EDT
Smolt rocks faces and totally closes this bug.

Note You need to log in before you can comment on or make changes to this bug.