Bug 204577 - Missing Dependency: libsemanage.so.1()(64bit) is needed by package policycoreutils
Missing Dependency: libsemanage.so.1()(64bit) is needed by package policycore...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libsepol (Show other bugs)
5
ppc64 Linux
medium Severity high
: ---
: ---
Assigned To: Luke Macken
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-30 02:06 EDT by Kir Kolyshkin
Modified: 2016-09-19 22:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-08 23:14:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kir Kolyshkin 2006-08-30 02:06:56 EDT
Description of a problem:
There is a package in FC5 ppc updates repository: policycoreutils-1.30.10-2.fc5

It is provided for both ppc and ppc64 arches, i.e. there are:
   policycoreutils-1.30.10-2.fc5.ppc.rpm
   policycoreutils-1.30.10-2.fc5.ppc64.rpm

The problem is policycoreutils requires libsepol, but there is NO libsemanage
for ppc64 arch provided, i.e. there is only:
   libsemanage-1.6.2-2.fc5.ppc.rpm

That makes yum impossible to install full FC5 ppc system into an empty chrooted
environment.

Version-Release number of selected component (if applicable):
policycoreutils-1.30.10-2.fc5
libsemanage-1.6.2-2.fc5

How reproducible:
Always

Steps to Reproduce:
(on a ppc64 box)
1. mkdir /tmp/fc5
2. rpm --root /tmp/fc5 --initdb
3. yum --installroot /tmp/fc5 install basesystem
  
Actual results:
Error: Missing Dependency: libsemanage.so.1(LIBSEMANAGE_1.0)(64bit) is needed by
package policycoreutils
Error: Missing Dependency: libsemanage.so.1()(64bit) is needed by package
policycoreutils


Expected results:
Succesfully installed system

Additional info:
I found the following but while developing OpenVZ for powerpc.
I set high severity because this makes FC5 ppc repository non-consistent, and
this is a major bug IMO.
Comment 1 Daniel Walsh 2006-08-30 06:57:10 EDT
Jesse is this a build problem?  
Comment 2 Jesse Keating 2006-08-30 08:13:52 EDT
No, it's probably a config problem in that libsemanage isn't listed as multilib
for FC5.

Hrm, it appears that policycoreutils and libsemanage are BOTH not in the FC5
multilib list, so I'm not sure how policycoreutils-1.30.10-2.fc5.ppc64.rpm got
leaked into the repo.  Just libselinux is listed.  In FC6, policycoreutils isn't
multilib either, so I think we just need to remove it from the FC5 repo.
Comment 3 Kir Kolyshkin 2006-08-31 03:51:24 EDT
Can someone please check the _whole_ repository for such bugs? For example, I
see the following in the ppc updates repo:

procps-3.2.6-3.4.ppc64.rpm
procps-3.2.6-3.5.ppc.rpm

Looks like the repo is in bad state :(
Comment 4 Luke Macken 2006-10-08 23:14:10 EDT
I cleaned up[0] the ppc64 mess in the updates repositories, and
policycoreutils-1.30.10-2.fc5.ppc64.rpm is now gone.

[0]: https://www.redhat.com/archives/fedora-devel-list/2006-October/msg00241.html

Note You need to log in before you can comment on or make changes to this bug.