Bug 20459 - ImageMagick 5.2.2-5 does not handle xwd output from XFree86 3.3.6
ImageMagick 5.2.2-5 does not handle xwd output from XFree86 3.3.6
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ImageMagick (Show other bugs)
7.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
http://www.imagemagick.org/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-07 02:36 EST by Wesley Tanaka
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-07 02:36:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesley Tanaka 2000-11-07 02:36:42 EST
I have the following version of xwd, which I believe corresponds to an
XFree86 package I got from the 3dfx website.

~ % rpm -qf /usr/bin/X11/xwd
XFree86-3.3.6-15

I created a file using xwd:
xwd > /tmp/foo.xwd

I had the following version of convert:

rpm -qif `which convert`
Name        : ImageMagick                  Relocations: /usr/X11R6
Version     : 5.2.2                             Vendor: Red Hat, Inc.
Release     : 5                             Build Date: Wed 02 Aug 2000
12:33:57 PM PDT
Install date: Fri 15 Sep 2000 06:57:24 PM PDT      Build Host:
porky.devel.redhat.com
Group       : Applications/Multimedia       Source RPM:
ImageMagick-5.2.2-5.src.rpm
Size        : 4998912                          License: freeware
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.imagemagick.org/
Summary     : An X application for displaying and manipulating images.
Description :
ImageMagick(TM) is an image display and manipulation tool for the X
Window System.  ImageMagick can read and write JPEG, TIFF, PNM, GIF
and Photo CD image formats.  It can resize, rotate, sharpen, color
reduce or add special effects to an image, and when finished you can
either save the completed work in the original format or a different
one.  ImageMagick also includes command line programs for creating
animated or transparent .gifs, creating composite images, creating
thumbnail images, and more.

ImageMagick is one of your choices if you need a program to manipulate
and display images. If you'd also like to develop your own applications
which use ImageMagick code or APIs, you'll need to install
ImageMagick-devel as well.


I tried running convert:

/tmp % convert asdf.xwd asdf.gif
convert: XWD file format version mismatch (asdf.xwd) [No such file or
directory].
convert: Missing an image file name.



I grabbed the version of ImageMagick from rawhide:

/tmp % sudo rpm -Uvh ImageMagick-5.2.4-1.i386.rpm

and tried again:


/tmp % convert asdf.xwd foo.png
convert: error while loading shared libraries:
/usr/X11R6/lib/libMagick.so.5: symbol __fxstat64, version GLIBC_2.2 not
defined in file libc.so.6 with link time reference

so I looked to upgrade my glibc:

/tmp % rpm -qf /usr/X11R6/lib/libMagick.so.5
ImageMagick-5.2.4-1
/tmp % rpm -q glibc
glibc-2.1.92-5

I grabbed the glibc from rawhide:

/tmp % sudo rpm -Uvh glibc-2.1.95-2.i686.rpm

/tmp % convert asdf.xwd foo.png
/tmp % convert asdf.xwd foo.gif

/tmp % ls -l foo.gif foo.png
-rw-r--r--   1 wtanaka  wtanaka    171323 Nov  6 23:29 foo.gif
-rw-r--r--   1 wtanaka  wtanaka      7681 Nov  6 23:27 foo.png

and things worked.

So now I have:

rpm -qi ImageMagick glibc
Name        : ImageMagick                  Relocations: /usr/X11R6
Version     : 5.2.4                             Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Mon 25 Sep 2000
06:45:49 AM PDT
Install date: Mon 06 Nov 2000 11:19:45 PM PST      Build Host:
porky.devel.redhat.com
Group       : Applications/Multimedia       Source RPM:
ImageMagick-5.2.4-1.src.rpm
Size        : 5252896                          License: freeware
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.imagemagick.org/
Summary     : An X application for displaying and manipulating images.
Description :
ImageMagick(TM) is an image display and manipulation tool for the X
Window System.  ImageMagick can read and write JPEG, TIFF, PNM, GIF
and Photo CD image formats.  It can resize, rotate, sharpen, color
reduce or add special effects to an image, and when finished you can
either save the completed work in the original format or a different
one.  ImageMagick also includes command line programs for creating
animated or transparent .gifs, creating composite images, creating
thumbnail images, and more.

ImageMagick is one of your choices if you need a program to manipulate
and display images. If you'd also like to develop your own applications
which use ImageMagick code or APIs, you'll need to install
ImageMagick-devel as well.
Name        : glibc                        Relocations: (not relocateable)
Version     : 2.1.95                            Vendor: Red Hat, Inc.
Release     : 2                             Build Date: Thu 19 Oct 2000
10:32:21 AM PDT
Install date: Mon 06 Nov 2000 11:26:20 PM PST      Build Host:
porky.devel.redhat.com
Group       : System Environment/Libraries   Source RPM: glibc-2.1.95-2.src.rpm
Size        : 38815956                         License: LGPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : The GNU libc libraries.
Description :
The glibc package contains standard libraries which are used by
multiple programs on the system. In order to save disk space and
memory, as well as to make upgrading easier, common system code is
kept in one place and shared between programs. This particular package
contains the most important sets of shared libraries: the standard C
library and the standard math library. Without these two libraries, a
Linux system will not function.  The glibc package also contains
national language (locale) support and timezone databases.



I'm not sure if this is something that you care about issuing an errata
for, or if this even shows up in stock redhat 7.0 (since redhat 7.0 ships
with XFree86 4.0 as well as 3.3.6...  and it didn't look like I had the
latest build of the glibc...), although it seems likely that it does, if
someone has XFree 3.3.6 enabled somehow..

Just wanted to let you know so that you had more information rather than less.
Comment 1 Bernhard Rosenkraenzer 2000-11-08 03:20:46 EST
ImageMagick can currently support only one type of xwd formats - since we're using XFree86 4.0.1, that's the format we've enabled.
Comment 2 Wesley Tanaka 2000-11-08 03:28:22 EST
Any idea why rawhide's ImageMagick-5.2.4-1.i386.rpm works with the 3.3.6 xwd
format?

Note You need to log in before you can comment on or make changes to this bug.