Bug 204608 - anaconda set %_transaction_color in /etc/rpm/macros
anaconda set %_transaction_color in /etc/rpm/macros
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-08-30 08:20 EDT by Axel Thimm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-17 09:29:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2006-08-30 08:20:11 EDT
Currently on multilib systems anaconda writes a %_transaction_color entry into
the unowned /etc/rpm/macros file.

It looks like rpm for some ppc64/ia64a archs wasn't defaulting to 3, for x86_64
I checked that for all multilib releases (RHEL3/4 and FC2-6) the setting
%_transaction_color to 3, so it's doing the right thing w/o any entry in
/etc/rpm/macros.

If this has been fixed in ppc64's rpm could this entry be left off? Ideally
/etc/rpm/macros should be used only by users to modify rpm behaviour, it can
happen (there are a couple of bug reports in here), that this entry gets nuked,
especially since this currently /etc/rpm/macros is unowned (see also bug
#204606). Also if this entry is important many buildroot constructing systems
are missing this, so it should move from anaconda to rpm.

I suggest to

o either not set anything in /etc/rpm/macros if it is indeed redundand by now,
o or, if it is needed in some scenarios to place it into some other
  /etc/rpm/macros.* file and make that owned by some prominent package like rpm
  itself.
Comment 1 Jeremy Katz 2006-09-06 01:38:44 EDT
Unfortunately, this can't be not written out as on ppc you definitely don't get
the right thing (since you're running a ppc32 rpm instead of ppc64, chaos then
ensues).  There's a really old bug against rpm about this.

We could change it to /etc/rpm/macros.somethingelse, though I guess
Comment 2 Paul Nasrat 2007-05-17 09:29:41 EDT
We also need to set color preference now for ppc64 so we need to write out the
macros file

Note You need to log in before you can comment on or make changes to this bug.