This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 204611 - Excel "share workbook" feature broken by -excel patch in 3.0.9-1.3E.6 and later
Excel "share workbook" feature broken by -excel patch in 3.0.9-1.3E.6 and later
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-30 09:03 EDT by Peter J. Holzer
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:41:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter J. Holzer 2006-08-30 09:03:16 EDT
Description of problem:

MS Excel has a feature which allows several users to work on the same excel file
concurrently ("Arbeitsmappe freigeben" in German, probably "share workbook" in
English).

This feature doesn't work if the -excel patch introduced in 3.0.9-1.3E.6 is
applied. Even worse, if a user tries to use this feature, other users always get
a warning that the file is locked, even if they are currently the only one who
are accessing it. So, not only doesn't concurrent access work any more, even
serial access doesn't work. 

The same user (on two different clients) can open the file. So it's probably
some kind of permission problem, and since my file is writable for all, my 
guess is that Excel is trying to change some metadata (probably the timestamp).

If I rebuild the 3.0.9-1.3E.10 rpm without the -excel patch (patch24), sharing
workbooks works (but then Excel files change mtime if opened).

Version-Release number of selected component (if applicable):

3.0.9-1.3E.6 to 3.0.9-1.3E.10 (inclusive)

How reproducible:


Steps to Reproduce:
1. Create an Excel file on a Samba share. Make sure it is writable by other users
2. Open the file with excel and select "share workbook" from the menu. The title
bar should now indicate that the file is shared.
3. Log in as a different user and open the excel file.
  
Actual results:

You get an error message that the file is locked. You can still open it, and the
title bar indicates that the file is shared, but when you try to save it you get
an error message "you aren't connected to the file any more" (my translation
from German). You can only save it with a different file name.

Expected results:

The file should be opened without an error. Saving the file should be possible.

Additional info:

Excel is from Office XP (2002) but Excel 97 was also shortly tested. File system
is ext3 with ACLs and quotas enabled.
Comment 1 Peter J. Holzer 2006-08-30 11:46:03 EDT
I cannot reproduce the problem with the current version (3.0.23b) from samba.org.
The changelog indicates possibly relevant changes in 3.0.12 and 3.0.14.
Comment 2 RHEL Product and Program Management 2007-10-19 14:41:33 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.