Bug 204642 - Segmentation fault in executable edhead
Summary: Segmentation fault in executable edhead
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: wcstools (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Sergio Pascual
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-30 15:52 UTC by Pablo Pérez González
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 3.6.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 14:59:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes a problem with mkstemp (444 bytes, patch)
2006-08-30 22:51 UTC, Sergio Pascual
no flags Details | Diff

Description Pablo Pérez González 2006-08-30 15:52:56 UTC
Description of problem:

The command edhead gives a "Segmentation fault" when trying to use it in any 
fits image.

Version-Release number of selected component (if applicable): version 3.6.5


How reproducible: Always


Steps to Reproduce:
1.Use a fits image such as
http://nedwww.ipac.caltech.edu/img11/1985A+A...152..237B/MESSIER_081:I:20cm:bkk1985.fits.gz
2.After gunzipping it, try to run edhead: "> edhead MESSIER_081:I:20cm:bkk1985.fits"
3.See the Seg fault :(
 
Actual results: Segmentation fault


Expected results: Access the header to edit it.


Additional info: Version 3.6.4 of wcstools seems to work fine. It looks like a
wcstools source bug.

Comment 1 Sergio Pascual 2006-08-30 22:48:12 UTC
I have found out the problem, but the fedora cvs seems to be down at the moment.
I will create a new rpm ASAP. 

Thanks, Pablo :)

Comment 2 Sergio Pascual 2006-08-30 22:51:20 UTC
Created attachment 135249 [details]
Fixes a problem with mkstemp


Note You need to log in before you can comment on or make changes to this bug.