Bug 204653 - jc1: corrupted double-linked list
Summary: jc1: corrupted double-linked list
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-30 16:29 UTC by Anthony Green
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 2.4.90-28
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 06:57:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mock build log (171.72 KB, text/plain)
2006-08-30 16:29 UTC, Anthony Green
no flags Details

Description Anthony Green 2006-08-30 16:29:31 UTC
Description of problem:
I can't build some packages in rawhide with the current gcj.

See attached log file.

Version-Release number of selected component (if applicable):
gcc-java-4.1.1-20 

How reproducible:
Always

Steps to Reproduce:
1.Rebuilt the Fedora Extras itext package.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Anthony Green 2006-08-30 16:29:31 UTC
Created attachment 135224 [details]
mock build log

Comment 3 Jakub Jelinek 2006-08-30 19:39:42 UTC
What glibc was in the tree?
If it is glibc-2.4.90-{22,23,24}, then it is a known problem.
But rawhide has now 2.4.90-26.

Comment 4 Anthony Green 2006-08-30 19:49:26 UTC
(In reply to comment #3)
> What glibc was in the tree?
> If it is glibc-2.4.90-{22,23,24}, then it is a known problem.
> But rawhide has now 2.4.90-26.

The mock build root had 2.4.90-26.  See the URL referenced in comment #2.

Comment 5 Anthony Green 2006-08-30 19:50:36 UTC
Oops - I should have checked the "requested info" checkbox.

Comment 6 Jakub Jelinek 2006-08-30 21:14:45 UTC
Is it reproduceable?
I certainly can't reproduce it on my x86-64 box.
uname -m; rpm -q gcc-java glibc
x86_64
gcc-java-4.1.1-20
glibc-2.4.90-26
glibc-2.4.90-26
The jc1 process was eating a lot of memory during that command (around 750MB),
but hasn't failed.

Comment 7 Anthony Green 2006-08-30 23:04:36 UTC
(In reply to comment #6)
> Is it reproduceable?

Yes, it is reproducable in the FE build system.  Did you try building with mock?


Comment 8 Jakub Jelinek 2006-08-31 08:51:54 UTC
Yes, once in mock and twice outside of mock with current rawhide.
...
+ aot-compile-rpm
/usr/bin/gcj -c -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC
-findirect-dispatch -fjni itext-1.3.jar.1.jar -o itext-1.3.jar.1.o
/usr/bin/gcj -c -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC
-findirect-dispatch -fjni itext-1.3.jar.2.jar -o itext-1.3.jar.2.o
/usr/bin/gcj -shared -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC
-findirect-dispatch -fjni -Wl,-Bsymbolic itext-1.3.jar.1.o itext-1.3.jar.2.o -o
itext-1.3.jar.so
/usr/bin/gcj-dbtool -n itext-1.3.jar.db 64
for jar in itext-1.3.jar.1.jar itext-1.3.jar.2.jar; do \
            /usr/bin/gcj-dbtool -f itext-1.3.jar.db $jar \
                /usr/lib64/itext/itext-1.3.jar.so; \
        done
...

In each case the rpmbuild failed, but for a different reason:
error: File not found by glob:
/var/tmp/itext-1.3-1jpp_9.1.fc6-root-mockbuild/usr/lib64/gcj/*
(because the shared libraries etc. were installed to
/usr/lib64/itext/itext-1.3.jar.{db,so} and /usr/share/java/itext-1.3, rather
than /usr/lib64/gcj/).

Comment 10 Jakub Jelinek 2006-09-01 06:57:33 UTC
Should be fixed in glibc-2.4.90-28 in rawhide.


Note You need to log in before you can comment on or make changes to this bug.