Bug 20467 - Kernel mismatched to linux include files.
Kernel mismatched to linux include files.
Status: CLOSED DUPLICATE of bug 20292
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-07 09:16 EST by shawn.karow
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-08 06:27:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shawn.karow 2000-11-07 09:16:05 EST
I was attempting to build a module, earlier built on Redhat 6.2, on RedHat 
7.0. The module built no problem but when I went to install it I got the 
following error:

Warning: kernel-module version mismatch
/data/56/Release/pikadsp.o was compiled for kernel version 2.4.0-0.26
	while this kernel is version 2.2.16-22 

We include files from /usr/include/linux so I go there to check out the 
header files. I open version.h and indeed the kernel is defined as being 
2.4.0-0.26 even though I am running the 2.2.16-22 kernel. It seems to me 
that the header files included in the install are mismatched to the actual 
kernel that is installed.

I have a standard 7.0 Redhat install with no other kernels downloaded or 
installed on my system.
Comment 1 Arjan van de Ven 2000-11-08 06:27:52 EST
/usr/include/linux are the _GLIBC_ headers, not the kernel headers.
The kernel-headers are in  /usr/src/linux/include.
For Red Hat 6.2 these happened to be the same, but that was coincidence.....
Comment 2 Bill Nottingham 2000-11-13 02:31:12 EST

*** This bug has been marked as a duplicate of 20292 ***

Note You need to log in before you can comment on or make changes to this bug.