Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 204674 - FC5 Xemacs shells die when background process terminates
FC5 Xemacs shells die when background process terminates
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-30 15:11 EDT by Joshua Rosen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 17:01:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Rosen 2006-08-30 15:11:26 EDT
Description of problem:
Xemacs shells die when a background process ends. This is specific to FC5, it
doesn't happen on FC4 or any other distro.

Version-Release number of selected component (if applicable):

 tcsh --version
tcsh 6.14.00 (Astron) 2005-03-25 (x86_64-unknown-linux) options
wide,nls,dl,al,kan,rh,color,filec
/home/bjrosen> xemacs --version
Loading leim-list...
XEmacs 21.4 (patch 19) "Constant Variable" [Lucid] (x86_64-redhat-linux, Mule)
of Tue Apr  4 2006 on hammer1.fedora.redhat.com

How reproducible: 100%, it happens on all of my FC5 systems, both FC5 32 bit and
FC5 64 bit. The latest update to tcsh didn't fix it (Aug 30).


Steps to Reproduce:
Any background process that terminates will also kill the tcsh shell. The
simplest case is to do a ls >& log &.

1.start a shell (M-x shell)
2.ls >& log &
3.
  
Actual results:

 ls >& log &
[1] 12217
/home/bjrosen> exit

Process tcsh finished
Expected results:
tcsh shouldn't quit

Additional info:
Comment 1 Jens Petersen 2006-08-31 00:11:23 EDT
So it only happens when SHELL is tcsh?
Comment 2 Joshua Rosen 2006-08-31 09:12:33 EDT
Yes it's strictly a tcsh problem, it doesn't happen with bash.
Comment 3 Ville Skyttä 2006-09-02 06:39:59 EDT
Does upgrading the xemacs-base package to the current beta have any effect?

mkdir -p ~/.xemacs/xemacs-packages
cd ~/.xemacs/xemacs-packages
wget http://ftp.xemacs.org/beta/experimental/packages/xemacs-base-2.08-pkg.tar.gz
tar zxvf xemacs-base-2.08-pkg.tar.gz

Others seem to have experienced the same problem:
http://www.gatago.com/comp/emacs/xemacs/24321567.html
Comment 4 Joshua Rosen 2006-09-02 11:04:12 EDT
No upgrading the basic packages doesn't help however when I downloaded the
current sumo tarball from Xemacs.org and installed in in .xemacs it fixed the
problem.



Comment 5 Joshua Rosen 2006-09-02 16:31:22 EDT
I was wrong when I said that installing the current sumo tarball fixed the
problem. I tried that on a second machine and it had no effect. I also tried
building from source, both the current version and the 21.5.27 beta, that had no
effect. 

It looks like the failure isn't always immediate, when Xemacs is started it
takes a couple of tries before the problem occurs.

home/bjrosen> ls -1 >& log &
[1] 19240
[1]    Done                          ls -1 >& log
/home/bjrosen> ls -1 >& log &
[1] 19241
[1]    Done                          ls -1 >& log
/home/bjrosen> ls -1 >& log &
[1] 19243
/home/bjrosen> exit

Process tcsh finished
Comment 6 Ville Skyttä 2007-06-14 16:24:00 EDT
Do xemacs 21.5.28 and up to date elisp packages on FC6+ still exhibit the
problem too?  I'm having problems reproducing this.
Comment 7 Joshua Rosen 2007-06-14 16:33:12 EDT
I'm not having this problem on FC6, this was strictly an FC5 issue.
Comment 8 Ville Skyttä 2007-06-14 17:01:26 EDT
Ok, thanks for the confirmation.  Given that FC5's EOL is in two weeks and this
is not a security issue, it's very unlikely that this would be addressed in it
any more, so closing.

Note You need to log in before you can comment on or make changes to this bug.