Bug 204682 - kernel BUG in shrink_dcache_for_umount_subtree
kernel BUG in shrink_dcache_for_umount_subtree
Status: CLOSED DUPLICATE of bug 206036
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
high Severity urgent
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-30 16:16 EDT by IBM Bug Proxy
Modified: 2015-01-04 17:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-17 01:40:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 26734 None None None Never

  None (edit)
Description IBM Bug Proxy 2006-08-30 16:16:02 EDT
LTC Owner is: ed_pollard@us.ibm.com

Problem description:
kernel BUG in shrink_dcache_for_umount_subtree at fs/dcache.c:615!

Aug 29 snapshot of rawhide: 
kernel-2.6.17-1.2597.fc6.ppc64.rpm

development/source/SRPMS/
kernel-2.6.17-1.2597.fc6.src.rpm
anaconda-11.1.0.84-1.src.rpm

Hardware Environment
    Machine type (p650, x235, SF2, etc.): OpenPower720  (9124-720)
    Cpu type (Power4, Power5, IA-64, etc.):Power5

    Describe the steps:
choose dhcp for eth0 and start an NFS install (recreates with ftp install too)
welcome to Fedora screen (ok)
Warning: this is a beta (choose: install anyway)
anaconda starts to run and lpar crashes.
Additional information:
          ┌──────────────────────┤ Searching ├──────────────────────�?
          │                                                         │
          │ Searching for Fedora Core installations...              │
          │                                                         │
          │                            0%                          cpu 0x3:
Vector: 700 (Program Check) at [c0000000484c3690]                              
         │
    pc: c0000000000ff550: .shrink_dcache_for_umount_subtree+0x204/0x304
    lr: c0000000000ff54c: .shrink_dcache_for_umount_subtree+0x200/0x304
    sp: c0000000484c3910
   msr: 8000000000029032
  current = 0xc00000008556a250
  paca    = 0xc000000000494980
    pid   = 914, comm = anaconda
kernel BUG in shrink_dcache_for_umount_subtree at fs/dcache.c:615!
enter ? for help
3:mon>

[c0000000484c39a0] c00000000010036c .shrink_dcache_for_umount+0x50/0x74
[c0000000484c3a20] c0000000000e8620 .generic_shutdown_super+0x3c/0x1b0
[c0000000484c3ab0] c0000000000e87c4 .kill_block_super+0x30/0x60
[c0000000484c3b40] c0000000000e8980 .deactivate_super+0xd4/0x128
[c0000000484c3bd0] c000000000105ac4 .mntput_no_expire+0x84/0x10c
[c0000000484c3c60] c0000000000f15ec .path_release_on_umount+0x30/0x48
[c0000000484c3cf0] c00000000010671c .sys_umount+0x300/0x36c
[c0000000484c3e30] c00000000000871c syscall_exit+0x0/0x40
--- Exception: c01 (System Call) at 000000000fbdf438
SP (fa16f150) is in userspace
3:mon> r
R00 = c0000000000ff54c   R16 = 00000000f7de9e90
R01 = c0000000484c3910   R17 = 00000000f7d52260
R02 = c0000000005b2c80   R18 = 0000000000000000
R03 = 0000000000000062   R19 = 00000000100201b8
R04 = 8000000000001032   R20 = 0000000000000000
R05 = 0000000000000000   R21 = 00000000f7d540ad
R06 = 0000000000000000   R22 = 0000000010048f90
R07 = 0000000000000000   R23 = 00000000100490e8
R08 = 0000000000000002   R24 = 000000000fea41b0
R09 = c000000000650000   R25 = 0000000000000000
R10 = 000000001c00000f   R26 = 0000000010048f90
R11 = 0000000000000000   R27 = 0000000000000000
R12 = 0000000000004000   R28 = c0000000874f7450
R13 = c000000000494980   R29 = c000000086dec528
R14 = 00000000ffffffff   R30 = c0000000004e7fa0
R15 = 00000000f7d54034   R31 = c000000086dec428
pc  = c0000000000ff550 .shrink_dcache_for_umount_subtree+0x204/0x304
lr  = c0000000000ff54c .shrink_dcache_for_umount_subtree+0x200/0x304
msr = 8000000000029032   cr  = 24228882
ctr = 80000000001c5840   xer = 0000000000000000   trap =  700
 

I set this to anaconda because I can't find anything closer for an install
problem, please let me know what component would better suit to avoid
misdirection in teh future if this is incorrect.
Comment 1 IBM Bug Proxy 2006-08-30 19:41:27 EDT
----- Additional Comments From marksmit@us.ibm.com  2006-08-30 19:39 EDT -------
This again recreates on multiple Power5 systems using todays Aug 30 snapshot of
rawhide. 
Comment 2 Janice Girouard - IBM on-site partner 2006-08-31 15:33:52 EDT
setting the priority to high to be consistent with the severity field.
Comment 3 Janice Girouard - IBM on-site partner 2006-08-31 16:27:15 EDT
possibly this is a duplicate of
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=200645
Comment 4 Janice Girouard - IBM on-site partner 2006-08-31 16:44:47 EDT
given this bug is found in 2597.fc6, and the above was fixed by 2505.fc6, this
looks related but not identical to 200645.   Adding davej@readhat.com to cc
list, as he posted the fix for 200645. 
Comment 5 IBM Bug Proxy 2006-08-31 16:46:55 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
          Component|Installation and Packaging  |Kernel




------- Additional Comments From marksmit@us.ibm.com  2006-08-31 16:40 EDT -------
changing component to kernel to match similar bug 200645 
Comment 6 IBM Bug Proxy 2006-09-01 13:46:04 EDT
----- Additional Comments From marksmit@us.ibm.com  2006-09-01 13:41 EDT -------
recreates on Aug31 and Sept1 snapshots of rawhide 
Comment 7 David Lawrence 2006-09-05 11:56:25 EDT
Changing to proper owner, kernel-maint.
Comment 8 IBM Bug Proxy 2006-09-14 01:07:45 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|block                       |high




------- Additional Comments From marksmit@us.ibm.com  2006-09-13 17:37 EDT -------
I have experimented enough to see that this still recreates on the Sept 11
version of rawhide. However, I can make it come or go by putting a reiserfs
partition on the disk.   
Beginning the install process, when anaconda searches for existing Fedora Core
installations, if it encounters a reiserfs partition, this problem recreates.
If I boot in rescue mode and use parted to remove the reiserfs partition, then
this problem does not recreate. 
Comment 9 IBM Bug Proxy 2006-09-14 01:10:52 EDT
----- Additional Comments From marksmit@us.ibm.com  2006-09-13 19:52 EDT -------
reducing ltc severity to high from blocker.

I have verified that this recreates on Fedora Core6 - test3. However, I can make
it come or go by putting a reiserfs partition on the disk.   
Beginning the install process, when anaconda searches for existing Fedora Core
installations, if it encounters a reiserfs partition, this problem recreates.
If I boot in rescue mode and use parted to remove the reiserfs partition, then
this problem does not recreate. 
Comment 10 Dave Jones 2006-09-17 01:40:28 EDT

*** This bug has been marked as a duplicate of 206036 ***

Note You need to log in before you can comment on or make changes to this bug.