Bug 204723 - Mozilla Thunderbird appears unlocalized
Mozilla Thunderbird appears unlocalized
Status: CLOSED DUPLICATE of bug 204453
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: thunderbird (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-31 03:44 EDT by Yue Shi Lai
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 00:31:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yue Shi Lai 2006-08-31 03:44:18 EDT
Description of problem:

1. Although Mozilla Thunderbird includes a set of language packs as extentions, 
it does not use them. The reason is the startup script lacks the mechanism to 
specify -UIlocale according to the environmental variable $LANG.

2. Mozilla Thunderbird further lacks dictionaries for all spellings beside 
en_US.

Version-Release number of selected component (if applicable):

1.5.0.5-0.el4.2

How reproducible:

Always

Steps to Reproduce:
1. Set e,g, LANG=de_DE.UTF-8 or anything recognizably different than en_US.
2. Run thunderbird.
3. Click on "compose", click on the message field, and try to select an non-US 
spelling.
  
Actual results:

Thunderbird always starts in en_US, there is only en_US spelling check 
available.

Expected results:

Similar to the behavior of Firefox, Thunderbird should start in the language 
specified by $LANG. Spelling checks beside en_US should be available.

Additional info:

The dictionary problem can be fixed by download them from http://
www.mozilla.com/thunderbird/dictionaries.html and include them under the path /
usr/lib/thunderbird-1.5.0.5/components/myspell .

Refer Bug 202352 for the way to specify -UIlocale when calling the Mozilla 
binary. For example, include the following lines after the line 
"ALREADY_RUNNING=`check_running`" will fix the problem:

# Try without a local variant first, then with a local variant
# So that pt-BR doesn't try to use pt for example
SHORTMOZLOCALE=`echo $LANG | sed "s|_\([^.]*\).*||g"`
[ -f $MOZILLA_FIVE_HOME/extensions/langpack-
${SHORTMOZLOCALE}@thunderbird.mozilla.org/chrome/$SHORTMOZLOCALE.jar ] && 
MOZARGS="-UILocale $SHORTMOZLOCALE"

MOZLOCALE=`echo $LANG | sed "s|_\([^.]*\).*|-\1|g"`
[ -f $MOZILLA_FIVE_HOME/chrome/$MOZLOCALE.jar -o \
  -f $MOZILLA_FIVE_HOME/extensions/langpack-
${MOZLOCALE}@thunderbird.mozilla.org/chrome/$MOZLOCALE.jar ] && MOZARGS="-
UILocale $MOZLOCALE"
Comment 1 Christopher Aillon 2006-09-01 00:31:22 EDT

*** This bug has been marked as a duplicate of 204453 ***

Note You need to log in before you can comment on or make changes to this bug.