Bug 204727 - Unicode representation of user's full name.
Unicode representation of user's full name.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
David Lawrence
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-31 05:06 EDT by Debarshi Ray
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 18:11:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Debarshi Ray 2006-08-31 05:06:01 EDT
Description of problem:
While creating a new user or editing an existing one, one can not type the full
name of the user in Unicode (using Ctrl+<space> to get the SCIM menu). However
the same string can be copy-pasted from somewhere else (eg., GEdit).

Version-Release number of selected component (if applicable):
1.2.42

How reproducible:
Can be reproduced every time as follows:

Steps to Reproduce:
1. Open system-config-users: # system-config-users
2. Double-click an existing user, or try to create a new one.
3. Try to type the user's full name in Unicode, using ctrl+<space> to get the
SCIM menu.
  
Actual results:
Menu would not pop-up, although it is possible to copy paste from somewhere
else, like GEdit

Expected results:
A SCIM menu ought to have popped out to allow the user to chose the language.

Additional info:
n.a.
Comment 2 Akira TAGOH 2006-09-01 01:32:35 EDT
GTK_IM_MODULE environment variable seems to be ignored - for testing, I did
enable the IM context menu, and when s-c-users runs, current IM pointed to XIM.
it works after changing it to scim from the IM context menu. I'm not sure why.
consolehelper may drops the environment variables perhaps like sudo does in some
case?
Comment 3 Nils Philippsen 2006-09-01 03:32:15 EDT
Reassigning to usermode then, this is nothing I can fix in s-c-users.
Comment 4 Miloslav Trmač 2007-03-13 18:41:30 EDT
Matthias, can you please confirm that using an user-supplied, untrusted
GTK_IM_MODULE value within a GTK+ application run by root is secure?

Also, can any of the substrings "..", "/" and "%" legitimately appear in the
value  of GTK_IM_MODULE?
Comment 5 Debarshi Ray 2007-05-24 15:11:26 EDT
This issue is present in Rawhide (updated Fedora 7 test 4) as well.
Comment 6 A S Alam 2007-11-16 00:55:54 EST
with latest rawhide (after F8 release), problem continue...

usermode-1.93.1-1.fc8
Comment 7 Miloslav Trmač 2007-11-18 06:10:07 EST
Matthias?
Comment 8 Matthias Clasen 2007-11-18 10:14:32 EST
In reponse to comment #4: no, I cannot confirm that.

Running GUI applications as root is really not the right approach, and the gtk
team has been saying that for years. See PolicyKit for how to do this right.
Comment 9 Jens Petersen 2007-11-19 00:16:50 EST
(In reply to comment #4)
> Also, can any of the substrings "..", "/" and "%" legitimately appear in the
> value  of GTK_IM_MODULE?

Normally GTK_IM_MODULE is just the name of the gtk immodule:
eg "scim" or "scim-bridge".
Comment 10 Miloslav Trmač 2007-11-20 18:11:19 EST
(In reply to comment #8)
> In reponse to comment #4: no, I cannot confirm that.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.