Bug 204734 - Kernel panic after upgrade to 2.6.9-42.0.2 (root under LVM2)
Kernel panic after upgrade to 2.6.9-42.0.2 (root under LVM2)
Status: CLOSED DUPLICATE of bug 204733
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Brian Brock
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-31 07:32 EDT by igor
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 13:26:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description igor 2006-08-31 07:32:01 EDT
Description of problem:

After RHN upgrade from kernel-smp-2.6.9-5.EL to kernel-smp-2.6.9-42.0.2.EL, 
system with root partition under LVM2 does not boot.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux AS (2.6.9-42.0.2.ELsmp)
lvm2-2.02.06-6.0.RHEL4 
kernel-smp-2.6.9-42.0.2.EL

How reproducible:

always

Steps to Reproduce:

1. system was initially partitioned/formatted/installed with root partition 
under LVM2 using lvm2-2.00.31-1.0.RHEL4 and kernel-smp-2.6.9-5.EL
2. via RHN, it was upgraded (without any problems) to lvm2-2.02.06-6.0.RHEL4 
and kernel-smp-2.6.9-42.0.2.EL
3. system reboot with new kernel results in kernel panic
  
Actual results:

System boot normally with old kernel; with new kernel boot aborts with 'kernel 
panic':

   Booting 'Red Hat Enterprise Linux AS (2.6.9-42.0.0.ELsmp)'

root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.9-42.0.0.ELsmp ro root=/dev/VolGroup00/LogVol00
   [Linux-bzImage, setup=0x1400, size=0x15f4d2]
initrd /initrd-2.6.9.-42.0.2.ELsmp.img
   [Linux-initrd @ 0x32edc000, 0x113561 bytes]

Uncompressing Linux... Ok, booting the kernel.
ide0: I/O resource 0x1F0-0x1F7 not free.
ide0: ports already in use, skipping probe
Red Hat nash version 4.2.1.8 starting
  Reading all physical volumes. This may take a while...
  No volume groups found
  Volume group "VolGroup00" not found
ERROR: /bin/lvm exited abnormally! (pid 341)
mount: error 6 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempting to kill init!

Expected results:
System boots normally with new kernel.
Comment 1 igor 2006-08-31 07:38:04 EDT
pushed submit twice; this should be closed as duplicate of 204733 (it seems I 
have no rights to do that)
Comment 2 Tom Coughlan 2006-08-31 08:27:54 EDT

*** This bug has been marked as a duplicate of 204733 ***
Comment 3 Peter Martuccelli 2006-09-18 13:26:59 EDT

*** This bug has been marked as a duplicate of 204733 ***

Note You need to log in before you can comment on or make changes to this bug.