Bug 204739 - Bluecurve icon theme needs update for new icon locations
Summary: Bluecurve icon theme needs update for new icon locations
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-artwork (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Desktop
TreeView+ depends on / blocked
 
Reported: 2006-08-31 11:45 UTC by Joachim Frieben
Modified: 2013-03-13 04:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-13 15:21:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2006-08-31 11:45:47 UTC
Description of problem:
The location of some common icons has changed in the current "GNOME"
development branch. Consequently, although "Bluecurve" is chosen as
desktop theme, concerned applications do not use "Bluecurve" icons
which actually exist but do fall back to stock "GNOME" icons. In
particular "GNOME" icons of "stock_volume-*.png" and of "trashcan_*.png"
are used instead of their existing "Bluecurve" counterparts.

Version-Release number of selected component (if applicable):
redhat-artwork-5.0.2-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. Log in to "GNOME" session.
2. Set desktop icon theme to "Bluecurve"
  
Actual results:
Stock "GNOME" icons are used where "Bluecurve" icons exist.

Expected results:
A "Bluecurve" icon is used unless its actually missing from the theme.

Additional info:
As part of the official "Fedora" artwork package, the "Bluecurve"
theme should be updated to ensure proper function with current "GNOME"
versions, even if development effort is focusing on the new "Echo"
theme.

Comment 1 Matthias Clasen 2006-09-10 18:13:48 UTC
Since we are not going to get Echo into FC6, we need to do at least some
minimal coverage improvement for Bluecurve, by creating links for the icon-naming
spec 

Comment 2 Joachim Frieben 2006-09-10 19:38:52 UTC
As far as I understand, "Bluecurve" will be around for quite a while
and probably be the default theme of upcoming "RHEL5". Why "minimal"
coverage improvement then?

Comment 3 Matthias Clasen 2006-09-13 15:21:46 UTC
Should be improved a lot in redhat-artwork-5.0.5-1.fc6. 
If you see specific problems with the coverage in that package, please
file individual bugs.


Note You need to log in before you can comment on or make changes to this bug.