Bug 204742 - mkinitrd heuristics for setting 'needusb' break for LVM
mkinitrd heuristics for setting 'needusb' break for LVM
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mkinitrd (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Lane
Kevin Baker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-31 08:15 EDT by lars
Modified: 2014-12-01 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-27 13:59:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for simpler building of usb-enabled initrd images. (976 bytes, patch)
2006-08-31 08:15 EDT, lars
no flags Details | Diff

  None (edit)
Description lars 2006-08-31 08:15:45 EDT
With root on an LVM VG that includes a USB attached disk, it's not possible to have mkinitrd 
automatically generate a working initrd image (it is possible if you manually specify the appropriate 
modules with --preload).

The problem is largely the small block of code that attempts to figure out whether or not the USB 
modules are necessary by explicitly checking to see if /boot or /root is on a USB attached device.  This 
test is far too clever by half, and in an LVM environment will never succeed.

Rather than trying to "fix" the test so that it works correctly, I think the best solution is to simply 
remove this test and have the "--with-usb" command line option simply cause mkinitrd to include the 
USB modules.  Trying to outsmart the sysadmin with clever shell scripts is generally a recipe doomed to 
failure.

I've attached a patch to mkinitrd that makes this change.
Comment 1 lars 2006-08-31 08:15:45 EDT
Created attachment 135277 [details]
Patch for simpler building of usb-enabled initrd images.

Note You need to log in before you can comment on or make changes to this bug.