Bug 2047493 - No EPG Data in VDR GUI - error in log: undefined symbol: PyObject_Repr
Summary: No EPG Data in VDR GUI - error in log: undefined symbol: PyObject_Repr
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vdr-epg2vdr
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: MartinKG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-27 22:14 UTC by Ronald Wahl
Modified: 2022-02-22 01:17 UTC (History)
1 user (show)

Fixed In Version: vdr-epg2vdr-1.2.6-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-22 01:17:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Ronald Wahl 2022-01-27 22:14:17 UTC
Description of problem:
No EPG information in VDR frontend. Maybe caused by this error in the log:

vdr[30484]: [30484] loading plugin: /usr/lib64/vdr/libvdr-epg2vdr.so.2.4.7
vdr[30484]: [30484] ERROR: /usr/lib64/vdr/libvdr-epg2vdr.so.2.4.7: undefined symbol: PyObject_Repr
runvdr[30484]: vdr: /usr/lib64/vdr/libvdr-epg2vdr.so.2.4.7: undefined symbol: PyObject_Repr

Version-Release number of selected component (if applicable):
vdr-epg2vdr-1.2.5-1.fc35.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Configure and start VDR, EPGD, MARIADB
2. journalctl will show the above error message
3.

Actual results:
Error message / no EPG data in VDR GUI

Expected results:
No Error message / EPG data in VDR GUI

Additional info:
Discussion (german) and possible solution here: https://www.vdr-portal.de/forum/index.php?thread/133185-vdr4arch-epg2vdr-scraper2vdr/

Comment 1 MartinKG 2022-01-28 08:54:32 UTC
I have not used the plugin for a while and am now a bit confused about the error message. The plugin is up to date with the python3 version.
I currently do not know how to solve this :-(

Comment 2 Ronald Wahl 2022-01-28 09:52:16 UTC
The issue is that the plugin is not linked against python:

$ ldd /usr/lib64/vdr/libvdr-epg2vdr.so.2.4.7
        linux-vdso.so.1 (0x00007fff69734000)
        /usr/lib64/gtk3-nocsd.so (0x00007feb8ce5a000)
        libm.so.6 => /lib64/libm.so.6 (0x00007feb8cd61000)
        libcrypto.so.1.1 => /lib64/libcrypto.so.1.1 (0x00007feb8ca73000)
        libuuid.so.1 => /lib64/libuuid.so.1 (0x00007feb8ca6a000)
        libtinyxml2.so.7 => /lib64/libtinyxml2.so.7 (0x00007feb8ca52000)
        libmariadb.so.3 => /lib64/libmariadb.so.3 (0x00007feb8c9fc000)
        libjansson.so.4 => /lib64/libjansson.so.4 (0x00007feb8c9ea000)
        libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007feb8c7cb000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007feb8c7b0000)
        libc.so.6 => /lib64/libc.so.6 (0x00007feb8c5a6000)
        /lib64/ld-linux-x86-64.so.2 (0x00007feb8cf01000)
        libz.so.1 => /lib64/libz.so.1 (0x00007feb8c58c000)
        libssl.so.1.1 => /lib64/libssl.so.1.1 (0x00007feb8c4ef000)

The build process must ensure to specify the required python libs when linking the plugin.

Comment 3 Fedora Update System 2022-01-28 13:20:49 UTC
FEDORA-2022-4a7bfc854f has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-4a7bfc854f

Comment 4 Ronald Wahl 2022-01-28 14:42:53 UTC
Great, it works! Thanks! 🐝🐝🐝

Comment 5 Fedora Update System 2022-02-12 01:39:26 UTC
FEDORA-2022-4a7bfc854f has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-4a7bfc854f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-4a7bfc854f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2022-02-13 01:39:30 UTC
FEDORA-2022-be1a98d775 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-be1a98d775`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-be1a98d775

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2022-02-22 01:17:30 UTC
FEDORA-2022-be1a98d775 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.