This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 204797 - anaconda needs to require rhpl to be installed
anaconda needs to require rhpl to be installed
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-31 12:55 EDT by Joshua Jensen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-12 13:38:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2006-08-31 12:55:29 EDT
Description of problem:

Having problems with http kickstarting with --nobase
Anaconda hangs on bootloader section... anaconda debugging shows
anaconda going through the steps:

blah
blah
/usr/lib/booty/bootloaderInfo.py
File /usr/lib/python2.3/site-packages/rhpl/executil.py not found

Shouldn't anaconda be installing the rhpl package regardless of package
selection, just like it does the booty package, since it actually requires rhpl
to be installed when writing the bootloader?


Version-Release number of selected component (if applicable):

RHEL4 U4 x86_64

How reproducible:

Do an http kickstart with:
%packages --nobase
Comment 1 Chris Lumens 2006-09-12 13:38:15 EDT
This will be fixed in the next build of anaconda.  If you require this fix in an
updated version of RHEL, please talk to your support representative who will
raise the issue through the proper channels.  For now, it's simple enough for
you to work around this problem by just adding rhpl to your packages section.
Comment 2 Joshua Jensen 2006-09-15 15:48:10 EDT
Sounds good.  How is this fixed specifically?  Is anaconda always going to
install rhpl specificially, regardless of the contents of the %packages section?
Comment 3 Chris Lumens 2006-09-15 16:43:23 EDT
We're keeping a list of packages that anaconda requires to have installed on the
system for things that we do post-installation.  These will be installed
regardless of what you do in kickstart because they are selected after all the
%packages section processing has occurred.
Comment 4 Joshua Jensen 2006-09-16 17:42:59 EDT
Perfect.... so far I've stumbled into these four being missing:

rhpl
system-config-mouse
grub
authconfig

Thanks!

Note You need to log in before you can comment on or make changes to this bug.