Bug 204806 - /etc/hosts ignored for resolving remote hosts for delivery
/etc/hosts ignored for resolving remote hosts for delivery
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: postfix (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-31 13:42 EDT by Charles Gillet
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 12:03:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Gillet 2006-08-31 13:42:56 EDT
Description of problem:

/etc/hosts ignored for resolving aliases (hosts: files dns in nsswitch) after
upgrade to U4

Version-Release number of selected component (if applicable):
 
postfix-2.2.10-1.RHEL4.2

How reproducible: consistently


Steps to Reproduce:
1. Use base postfix setup
2. put an alias that points to another mail gateway for delivery
/etc/aliases:
test:  test@test.redhat.net

3. if gateway is only in /etc/hosts (not in DNS) postfix will bounce message as
undeliverable because it can't resolve the name
  
Actual results:

bounces message as undeliverable - unable to resolve host address

Expected results:

should look in /etc/hosts, resolve from that file, and send the message to the
remote system

Additional info:
Comment 1 Charles Gillet 2006-09-21 17:43:10 EDT
Do I need to open a case with Redhat support to get an acknowledgement here? 
This change of behavior broke things on a production server.
Comment 2 Thomas Woerner 2006-09-25 08:50:41 EDT
Please set "smtp_host_loopup = native". THis should solve your problem.
Comment 3 Thomas Woerner 2006-09-25 08:51:27 EDT
smtp_host_lookup = native
Comment 4 Charles Gillet 2006-09-25 11:53:05 EDT
"smtp_host_lookup = native" does fix it.  Thanks!
Comment 5 Thomas Woerner 2006-09-25 12:03:55 EDT
Closing as "NOT A BUG".

Note You need to log in before you can comment on or make changes to this bug.