Bug 2048265 - Bluetooth: hci0: Malicious advertising data. Stopping processing
Summary: Bluetooth: hci0: Malicious advertising data. Stopping processing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-30 17:32 UTC by itrymybest80
Modified: 2022-02-06 02:02 UTC (History)
26 users (show)

Fixed In Version: kernel-5.16.5-200.fc35 kernel-5.16.5-100.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-05 01:21:56 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description itrymybest80 2022-01-30 17:32:54 UTC
Description of problem: error spam messages in dmesg?

Version-release number of selected component (if applicable): kernel-5.16.4-200.fc35.x86_64 gnome-shell-41.3-1.fc35.x86_64 bluez-5.63-1.fc35.x86_64

How reproducible: always.

Steps to reproduce:
1. enable your bluetooth adapter.
2. connect any kind of bluetooth device.
3. check dmesg for errors.

[12721.527780] Bluetooth: hci0: Malicious advertising data. Stopping processing
[12721.529845] Bluetooth: hci0: Malicious advertising data. Stopping processing
[12721.564780] Bluetooth: hci0: Malicious advertising data. Stopping processing
[12721.566832] Bluetooth: hci0: Malicious advertising data. Stopping processing
[12721.621838] Bluetooth: hci0: Malicious advertising data. Stopping processing
[12721.622783] Bluetooth: hci0: Malicious advertising data. Stopping processing
[12721.756775] Bluetooth: hci0: Malicious advertising data. Stopping processing
[12721.758783] Bluetooth: hci0: Malicious advertising data. Stopping processing
[12722.167870] Bluetooth: hci0: Malicious advertising data. Stopping processing
[12722.169901] Bluetooth: hci0: Malicious advertising data. Stopping processing

TP-Link UB400 Bluetooth 4.0 Nano USB adapter (v1.0)
0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Comment 1 Stan King 2022-02-01 00:27:34 UTC
I see this behavior with a prior version of the kernel on F35 5.15.17-200.fc35.x86_64.

(I don't yet have the 5.16.4 kernel mentioned by the original poster, nor do I see it available with "dnf --refresh check-update".)

The probable origin of the "malvertising" is my Logitech M720 Triathlon mouse, although I'm not absolutely certain.  The messages stop about 30 seconds after the mouse is powered off.  They take a while to resume when I power the mouse back on.

The two computers that have this behavior both have the Bluetooth USB interface "ID 8087:0a2a Intel Corp. Bluetooth wireless interface".

I was unable to reproduce this on a computer with the same kernel but with the newer interface "ID 8087:0029 Intel Corp. AX200 Bluetooth".

Let me know if I can help test or gather information on this.

Comment 2 Stan King 2022-02-01 00:54:50 UTC
I'd like to amend my comment 1: the message continues to be reported long after the possibly-offending mouse is powered off and moved 20 feet away.  There's definitely something interesting going on here.

Comment 3 Bastien Nocera 2022-02-01 09:00:30 UTC
It's a kernel bug. Patch:
https://lore.kernel.org/linux-bluetooth/20211124201628.405647-1-brian.gix@intel.com/

Comment 4 Justin M. Forbes 2022-02-01 13:34:07 UTC
This patch will be in 5.16.5 when it comes out.

Comment 5 Fedora Update System 2022-02-02 02:52:48 UTC
FEDORA-2022-57fd391bf8 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-57fd391bf8

Comment 6 Fedora Update System 2022-02-02 02:52:52 UTC
FEDORA-2022-667a5c6e26 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-667a5c6e26

Comment 7 Fedora Update System 2022-02-03 01:19:16 UTC
FEDORA-2022-667a5c6e26 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-667a5c6e26`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-667a5c6e26

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-02-03 01:34:25 UTC
FEDORA-2022-57fd391bf8 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-57fd391bf8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-57fd391bf8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2022-02-05 01:21:56 UTC
FEDORA-2022-57fd391bf8 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2022-02-06 02:02:14 UTC
FEDORA-2022-667a5c6e26 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.