Bug 2048323 - EasyEffects segfaults when attempting to use filters
Summary: EasyEffects segfaults when attempting to use filters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: easyeffects
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vasiliy Glazov
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-30 23:44 UTC by peoinas
Modified: 2022-02-04 01:22 UTC (History)
1 user (show)

Fixed In Version: easyeffects-6.2.3-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-04 01:22:38 UTC
Type: Bug


Attachments (Terms of Use)

Description peoinas 2022-01-30 23:44:55 UTC
Description of problem:
Due to a change in PipeWire, EasyEffects segfaults when trying to use any filter (in my case, the application refused to start altogether due to it attempting to autoload some filters). This bug is fixed in upstream: https://github.com/wwmm/easyeffects/issues/1362 -- updating EasyEffects to 6.2.3 resolves the issue, at least in my case.


Version-Release number of selected component (if applicable):
6.2.1-1

How reproducible:
100%

Steps to Reproduce:
1. Update PipeWire to 0.3.44
2. Attempt to start EasyEffects

Actual results:
EasyEffects segfaults.

Expected results:
EasyEffects starts as normal.

Additional info:

Comment 1 Vasiliy Glazov 2022-01-31 07:02:45 UTC
I can't reproduce it.
But I will upgrade package to 6.2.3.

Comment 2 Fedora Update System 2022-01-31 09:03:10 UTC
FEDORA-2022-5f10bb9b0b has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-5f10bb9b0b

Comment 3 Fedora Update System 2022-02-01 01:59:49 UTC
FEDORA-2022-5f10bb9b0b has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-5f10bb9b0b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-5f10bb9b0b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2022-02-04 01:22:38 UTC
FEDORA-2022-5f10bb9b0b has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.