Bug 2048656 - All build(config)s are shown in a component's topology view
Summary: All build(config)s are shown in a component's topology view
Keywords:
Status: CLOSED DUPLICATE of bug 2038879
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Jaivardhan Kumar
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-31 16:56 UTC by Andy Bartlett
Modified: 2022-02-01 16:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-01 16:02:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Andy Bartlett 2022-01-31 16:56:42 UTC
Description of problem:

Hi,
 My customer has reported:

When in Topology view, viewing a component with a buildconfig and builds, it also shows all other build configs present in the project.

Where are you experiencing the behavior? What environment?
Openshift Console


Version-Release number of selected component (if applicable):

OCP 4.8.20

How reproducible:

When there's multiple buildconfigs and at least 1 deploymentconfig.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

I'm expecting to see only the specific buildconfig and its builds related to the deploymentconfig, not buildconfigs that are unrelated to this deploymentconfig.

Additional info:

Comment 3 Jakub Hadvig 2022-02-01 06:01:42 UTC
I think this is expected behaviour but since its in the topology view I would rather make this statement by the Dev Team which owns the component.

Comment 4 Christoph Jerolimov 2022-02-01 16:02:32 UTC
Hi Andy, @andbartl

thanks for bringing up this issue. It was already reported as https://bugzilla.redhat.com/show_bug.cgi?id=2038879, we fixed this already in 4.10 and 4.9. The backport for is already prepared and hopefully merged and release with the next 4.8 z-stream release.

If you want you can link the customer issue against one of the linked customer issues in #2038879

*** This bug has been marked as a duplicate of bug 2038879 ***

Comment 5 Andy Bartlett 2022-02-01 16:21:59 UTC
Hi Christoph,
 Thanks for the update I will add the case to the 4.8 release.

Many thanks,

Andy


Note You need to log in before you can comment on or make changes to this bug.