Bug 2048819 - Resume from suspends hangs until a timeout reached (GDM/Gnome). removed fprintd = OK
Summary: Resume from suspends hangs until a timeout reached (GDM/Gnome). removed fprin...
Keywords:
Status: CLOSED DUPLICATE of bug 2019857
Alias: None
Product: Fedora
Classification: Fedora
Component: fprintd
Version: 35
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Benjamin Berg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-31 22:20 UTC by Flo H.
Modified: 2022-02-01 10:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-01 09:09:38 UTC
Type: Bug


Attachments (Terms of Use)

Description Flo H. 2022-01-31 22:20:34 UTC
Description of problem:

Machine would hang after resuming from standby until a timeout reached and then resume normally allowing to login (GDM/Gnome).

I initially thought Gnome Shell or GDM would crash (issue report [1]). After understanding the logs with help of Gnome Discourse ([2]), I figured fprintd is responsible for the hang. My Thinkpad T450s comes without a fingerprint reader. 

frpintd blocks and delaysthe login 

Once removed, the system would not hang a second after resuming from standby.

    Removed fprintd-1.94.1-1.fc35.x86_64     @@System
    Removed fprintd-pam-1.94.1-1.fc35.x86_64 @@System
    Removed libfprint-1.94.2-1.fc35.x86_64   @@System



[1]: https://gitlab.gnome.org/GNOME/gdm/-/issues/730
[2]: https://discourse.gnome.org/t/looking-for-help-debugging-and-reporting-a-bug/8775/5

Version-Release number of selected component (if applicable):
fprintd-1.94.1-1.fc35.x86_64 
gnome-shell-41.3-1.fc35.x86_64


Steps to Reproduce:
install f35 on 450s, update the system (or leave it), close the lid, open the lid, wakeup and then wait 30 secs before login or any tty is available.


Actual results:
Close lid, open lid, wake-up, wait, wait, login

Expected results:
Close lid sleep, Open lid, wakeup, login

Comment 1 Flo H. 2022-01-31 22:23:39 UTC
Here is a snippet from the journal, please let me know if you need further logs.

````

Jan 28 10:27:46 fedora audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fprintd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jan 28 10:31:23 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fprintd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jan 28 10:31:23 fedora fprintd[3419]: libusb: error [udev_hotplug_event] ignoring udev action change
Jan 28 10:31:23 fedora fprintd[3419]: libusb: error [udev_hotplug_event] ignoring udev action change
Jan 28 10:31:23 fedora fprintd[3419]: libusb: error [udev_hotplug_event] ignoring udev action change
Jan 28 10:31:23 fedora fprintd[3419]: libusb: error [udev_hotplug_event] ignoring udev action unbind
Jan 28 10:31:23 fedora fprintd[3419]: libusb: error [udev_hotplug_event] ignoring udev action change
Jan 28 10:31:23 fedora fprintd[3419]: libusb: error [udev_hotplug_event] ignoring udev action unbind
Jan 28 10:31:23 fedora fprintd[3419]: libusb: error [udev_hotplug_event] ignoring udev action change
Jan 28 10:31:53 fedora systemd[1]: fprintd.service: Deactivated successfully.

````

Comment 2 Benjamin Berg 2022-02-01 09:09:38 UTC
This will be btusb hanging again during firmware load. Marking as duplicate, please reopen if you can rule out that cause.

*** This bug has been marked as a duplicate of bug 2019857 ***

Comment 3 Benjamin Berg 2022-02-01 10:33:30 UTC
So, double checking the log file, I only see timeouts from USB 2-4, which seems to be the wwan modem (with a button, I guess, as there is a usbhid device for it). The timestamps are odd though, so not entirely sure.

So, I would suggest blacklisting btusb for a start, to confirm/rule out bug 2019857. Then, you could try blacklisting cdc_wdm, cdc_acm, cdc_mbim to see if that helps (not sure which one is the relevant one here). You can do that by adding a file to /etc/modprobe.d/disabled.conf or similar and just adding a row for each reading "blacklist btusb" and similar. After that, it is a good idea to run "dracut -f" and reboot.


Note You need to log in before you can comment on or make changes to this bug.