Bug 2048985 - votca-csg-tutorials depends on python2
Summary: votca-csg-tutorials depends on python2
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: votca
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Junghans
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: PYTHON2_EOL
TreeView+ depends on / blocked
 
Reported: 2022-02-01 09:44 UTC by Petr Viktorin
Modified: 2022-02-01 21:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-01 21:14:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Viktorin 2022-02-01 09:44:35 UTC
Python 2.7 reached end-of-life in January 2020, over 9 years after it was released. The python27 package is now deprecated in Fedora, but votca requires it.
Most likely this is due to the shebang in votca-2022/csg-tutorials/spce/ibi_espressopp/spce.py

Please remove the dependency on Python 2, or apply for a FESCo exception -- see https://fedoraproject.org/wiki/Changes/RetirePython2#FESCo_exceptions
I can help port the script to Python 3 if you give me some instructions on how to test it -- it looks simple, but unfortunately I have no idea what it's for.

If something is unclear, please mention it here.

Comment 1 Miro Hrončok 2022-02-01 12:08:39 UTC
$ dnf repoquery --repo=rawhide --requires votca-csg-tutorials
/usr/bin/bash
/usr/bin/python2
/usr/bin/python3
/usr/bin/sh
votca = 2022-1.fc36

Comment 2 Christoph Junghans 2022-02-01 16:25:43 UTC
We don't have a package for Espresso++ yet in Fedora, so I will just remove that tutorial for now.


Note You need to log in before you can comment on or make changes to this bug.