Bug 204929 - xsltproc crashes on PPC when processing PAM docs
Summary: xsltproc crashes on PPC when processing PAM docs
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: libxslt   
(Show other bugs)
Version: rawhide
Hardware: powerpc Linux
medium
high
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-01 13:50 UTC by Tomas Mraz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 16:08:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PAM Source RPM (6.77 MB, application/x-redhat-package-manager)
2006-09-01 13:50 UTC, Tomas Mraz
no flags Details

Description Tomas Mraz 2006-09-01 13:50:55 UTC
Description of problem:
xsltproc crashes on FC-devel PPC when processing PAM docs.

See
http://brewweb.devel.redhat.com/brew/getfile?taskID=201075&name=build.log

steps to reproduce - on PPC FC devel machine, install the attached src.rpm and
in doc/sag subdir run:
/usr/bin/xsltproc --stringparam base.dir html/ \
	  --stringparam root.filename Linux-PAM_SAG \
	  --stringparam use.id.as.filename 1 \
	  --stringparam chunk.first.sections 1 \
	  --stringparam section.autolabel 1 \
	  --stringparam section.label.includes.component.label 1 \
	  --stringparam toc.max.depth 2 --xinclude --nonet \
	  http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl
Linux-PAM_SAG.xml

Comment 1 Tomas Mraz 2006-09-01 13:51:02 UTC
Created attachment 135382 [details]
PAM Source RPM

Comment 2 Daniel Veillard 2006-11-02 16:08:41 UTC
Do we still have the problem ? There was a problem in libgcrypt breaking with
SELinux at some point, then the shared library could not be loaded. I assume
it's solved because xsltproc is used for a lot of our docs builds ...

Daniel

Comment 3 Tomas Mraz 2006-11-02 16:22:18 UTC
Yes, it was automagically resolved somehow after a day or two. I forgot to close
the bug report, sorry.


Note You need to log in before you can comment on or make changes to this bug.