Bug 204940 - RHEL4 Ux: ipmi kthread s/udelay(1)/schedule()/
RHEL4 Ux: ipmi kthread s/udelay(1)/schedule()/
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Martuccelli
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-01 11:00 EDT by Matt Domsch
Modified: 2007-11-16 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 23:32:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2006-09-01 11:00:49 EDT
Description of problem:
IPMI kernel thread for polling calls udelay(1) to slow down its poll rate,
rather than schedule().  This was fixed upstream on 2006-06-06 but it wasn't
clear it needed to be fixed in RHEL4.
http://marc.theaimsgroup.com/?l=linux-mm-commits&m=115135250417249&w=2

Since then we've started getting customer complaints about poor system
performance when running OMSA, which is somewhat alleviated (as best as can be
donw given the hardware design) with this patch.  It's a 1-liner,
s/udelay(1)/schedule()/.


This thread has more discussion of the patch.
http://marc.theaimsgroup.com/?l=linux-kernel&m=115135250429344&w=2

Please apply to the kernel at your earliest convenience.  I'll be rolling this
into the OpenManage 5.2 release currently scheduled for ~Q1FY2007.

Version-Release number of selected component (if applicable):
RHEL4 < Update 5
Comment 1 Issue Tracker 2006-09-13 14:03:31 EDT
File uploaded: kernel-smp-2.6.9-42.8.EL.IT101294.test.i686.rpm

This event sent from IssueTracker by sbenjamin 
 issue 101294
it_file 69341
Comment 2 Issue Tracker 2006-09-13 14:03:36 EDT
Ok have them try this test kernel out with the patch they provided to make
sure it works.  Once they've confirmed it works I will pass it along.

Internal Status set to 'Waiting on Support'

This event sent from IssueTracker by sbenjamin 
 issue 101294
Comment 5 Raghavendra Biligiri 2006-09-26 10:43:53 EDT
Test Kernel(kernel-smp-2.6.9-42.8.EL.IT101294.test.i686.rpm) works fine.
Issue is not reproducible with the test kernel.
Comment 6 RHEL Product and Program Management 2006-09-26 11:02:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Samuel Benjamin 2006-11-29 16:38:04 EST
Please add this to the code as soon as we start doing work for 4.5. Thanks.
Comment 8 Jason Baron 2006-12-13 14:35:08 EST
committed in stream U5 build 42.31. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 9 Raghavendra Biligiri 2006-12-15 06:31:00 EST
Issue is not reproducible with test kernel(kernel-2.6.9-42.32.EL).
Comment 12 Issue Tracker 2007-04-19 17:29:39 EDT
A fix for this issue has been included in RHEL4.5. Please test the Release
Candidate of RHEL4.5, which was released today to Partners, and let us know
if the problem is resolved. The Release Candidate can be downloaded from
here:

ftp://partners.redhat.com/af38ac4316ba20df2dec5f990913396d

Internal Status set to 'Waiting on Customer'
Status set to: Waiting on Client
Resolution set to: 'RHEL 4.5'

This event sent from IssueTracker by gcase 
 issue 101294
Comment 13 Red Hat Bugzilla 2007-05-07 23:32:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html

Note You need to log in before you can comment on or make changes to this bug.