Bug 204949 - Userspace sucks (wakeups)
Summary: Userspace sucks (wakeups)
Status: CLOSED DUPLICATE of bug 204948
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-01 16:48 UTC by David Woodhouse
Modified: 2014-03-17 03:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 16:50:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Woodhouse 2006-09-01 16:48:57 UTC
Our userspace sucks. It keeps waking up to poll things it really doesn't need to.
We should strive to be _entirely_ event-driven, as much as possible.

Constant wakeups will screw power consumption -- especially once we have the
kernel timer tick eliminated so we're actually waking the CPU for each userspace
stupidity.

Comment 1 David Woodhouse 2006-09-01 16:50:25 UTC

*** This bug has been marked as a duplicate of 204948 ***


Note You need to log in before you can comment on or make changes to this bug.