Bug 20496 - Crashes during installation
Crashes during installation
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-07 17:47 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-07 17:47:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-07 17:47:38 EST
During a text only install (I'm doing a new install of 7.0 over
a 6.2 install that was working great.... but whose upgrading was
failing due to file systems supposedly not being shut down 
properly... so as per RedHat installation support I'm doing a clean
install during which I reformat the / /usr and /var partitions)
of RedHat 7.0, I am repeatedly getting the following error message
dialog box after doing a custom selection of desired packages:

EXCEPTION OCCURRED

An internal error occurred in the installation program.
Please report this error to Red Hat (through the bugzilla.redhat.com
web site) as soon as possible.  The information on this failure
may be saved to a floppy disk, and will help Red Hat in fixing
the problem.  

Contents of the stuff saved to disk are as follows (sorry 
for the bad formatting ... now my intel box is dead so
I am copy / pasting while on a Mac):

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    
intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/
anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/
lib/anaconda/todo.py", line 1480, in doInstall
    if 
self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/
image.py", line 46, in systemMounted
    self.loopbackFile = mntPoint + 
fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//
usr/lib/anaconda/fstab.py", line 258, in filesystemSpace
    
space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  
File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return 
_isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or 
directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//
scratch

ToDo 
object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5

S'currentDisc'
p6
I1
sS'tree'
p7
S'/mnt/
source'
sS'device'
p8
S'hdb'
sS'progressWindow'
p9

<failed>

Any advice you can give would be greatly appreciated.

Thank you,

Steve Thorpe
thorpe@cnidr.org
Comment 1 Daniel Roesen 2000-11-07 17:49:29 EST
Errata update is available for the installer which fixes that problem.

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.