Bug 204965 - Preferences menu item appears not to do anything
Preferences menu item appears not to do anything
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-01 15:16 EDT by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 14:36:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2006-09-01 15:16:29 EDT
Description of problem:
The setroubleshoot browser window has an Edit->Preferences menu item.

Clicking on this menu item appears to do nothing.

Version-Release number of selected component (if applicable):
setroubleshoot-0.39-1
Comment 1 John Dennis 2006-09-07 16:13:47 EDT
Dan, since you've been in the process of cleaning up the menu items could you
take care of this one too? Thanks.
Comment 2 Daniel Walsh 2006-09-08 15:06:36 EDT
The only preference that I have heard is to keep the penquin alive all the time.

I guess we could add an email preference.  Any others?
Comment 3 John Dennis 2006-09-08 15:50:09 EDT
My thought had been that email preferences would be managed through the GUI but
you convinced me otherwise citing the server case for why they should be in the
config file.

With respect to keeping the status icon permanently visible that runs afoul of
the user interface guidelines which says status icons are temporal, visible only
when attention is required. If someone wants an easy way to bring the browser
back up then it can be iconified to the task bar like any other app. It used to
work that way, but I haven't checked recently -or- the user can bring it back up
via the System->Administration menu.

FWIW, I like the idea of managing preferences via a preferences dialog, but
unless we decide email preferences should be moved out of the config file I
don't think we have any preferences to mananage at the moment (but who knows,
perhaps that will change).
Comment 4 Daniel Walsh 2006-09-28 14:36:06 EDT
Removed preference menu for now in rawhide.

Note You need to log in before you can comment on or make changes to this bug.