This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 20499 - rpm ignore BuildPrereq: statement in the SPEC file
rpm ignore BuildPrereq: statement in the SPEC file
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-07 18:33 EST by Milan Kerslager
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-08 08:33:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2000-11-07 18:33:09 EST
RPM silently ignore the BuildPrereq statement in the SPEC file. I used rpm
-ba command.
The build process then fail by unresolved building dependencies.
Comment 1 Jeff Johnson 2000-11-08 08:13:28 EST
Add "--nodeps" to the build arguments if you wish to disable build dependency
checking.
Comment 2 Milan Kerslager 2000-11-08 08:33:07 EST
No, rpm *ignore* BuildPrereq: dependencies in SPEC file so when rebulding
packages the is no message about unresolved dependencies and compilation thus
fail (because there are no packages required by SPEC file in the system and rpm
did not inform about this unresolved dependencies). Simply BuildPrereq: do
nothing. I can write whatever here with no effect.
Comment 3 Jeff Johnson 2000-11-12 14:54:19 EST
Is your BuildPreReq: in the spec file preamble (i.e. near the top of the spec
file with other
tags?)

FWIW, I use BuildPreReq:'s routinely, and they "work for me" ...

Note You need to log in before you can comment on or make changes to this bug.