Bug 205001 - kernel BUG at fs/dquot.c (2.6.9-42.0.2.ELsmp)
kernel BUG at fs/dquot.c (2.6.9-42.0.2.ELsmp)
Status: CLOSED DUPLICATE of bug 209639
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-01 20:15 EDT by Thomas
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 11:01:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas 2006-09-01 20:15:22 EDT
Description of problem:  Various systems hard crashing on this kernel, problem
persisted on 2.6.9-34.0.2 -- output from logs:

Sep  1 16:44:07 northcarolina kernel: ------------[ cut here ]------------
Sep  1 16:44:07 northcarolina kernel: kernel BUG at fs/dquot.c:422!
Sep  1 16:44:07 northcarolina kernel: invalid operand: 0000 [#1]
Sep  1 16:44:07 northcarolina kernel: SMP
Sep  1 16:44:07 northcarolina kernel: Modules linked in: nfs lockd nfs_acl md5
ipv6 ipt_TOS iptable_mangle ip_conntrack_ftp ip_conntrack_irc ipt_REJECT
ipt_LOG ipt_limit iptable_filter ipt_multiport ipt_state ip_conntrack ip_tables
autofs4 sunrpc dm_mirror dm_mod button battery ac uhci_hcd ehci_hcd e1000
floppy sg ext3 jbd megaraid_mbox megaraid_mm sd_mod scsi_mod
Sep  1 16:44:07 northcarolina kernel: CPU:    0
Sep  1 16:44:07 northcarolina kernel: EIP:    0060:[<c01823db>]	 Not
tainted VLI
Sep  1 16:44:07 northcarolina kernel: EFLAGS: 00010202	 (2.6.9-42.0.2.ELsmp)
Sep  1 16:44:07 northcarolina kernel: EIP is at invalidate_dquots+0x3d/0xc3
Sep  1 16:44:07 northcarolina kernel: eax: 00000001   ebx: c2f30d40   ecx:
d4c2c200   edx: 00000000
Sep  1 16:44:07 northcarolina kernel: esi: d1448298   edi: 00000000   ebp:
f7f28c00   esp: c6482eec
Sep  1 16:44:07 northcarolina kernel: ds: 007b	 es: 007b   ss: 0068
Sep  1 16:44:07 northcarolina kernel: Process quotaoff (pid: 8265,
threadinfo=c6482000 task=e044a3b0)
Sep  1 16:44:07 northcarolina kernel: Stack: f7f28cac f7f28cac f7f28c00
00000000 c0183b80 00000000 00000000 f7f28c00
Sep  1 16:44:07 northcarolina kernel:	     00000000 00800003 c0185d1e
00000000 c0166267 80000300 e6b49880 c6482000
Sep  1 16:44:07 northcarolina kernel:	     f703bc2c fffffff4 c016f070
c6482f50 fffffff4 00000000 c0166484 f7f51880
Sep  1 16:44:07 northcarolina kernel: Call Trace:
Sep  1 16:44:07 northcarolina kernel:  [<c0183b80>]
vfs_quota_off+0x92/0x115
Sep  1 16:44:07 northcarolina kernel:  [<c0185d1e>]
do_quotactl+0x10d/0x4aa
Sep  1 16:44:07 northcarolina kernel:  [<c0166267>] getname+0x5b/0xb2
Sep  1 16:44:07 northcarolina kernel:  [<c016f070>] dput+0x34/0x1a7
Sep  1 16:44:07 northcarolina kernel:  [<c0166484>] path_release+0xa/0x2d
Sep  1 16:44:07 northcarolina kernel:  [<c016215b>] lookup_bdev+0x66/0x74


Version-Release number of selected component (if applicable):  2.6.9-42.0.2.ELsmp

Additional info:  Unable to reproduce, has affected 4 servers to date running
the same kernel versions.
Comment 1 Jason Baron 2006-10-31 10:41:51 EST
committed in stream U5 build 42.22. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 2 Linda Wang 2006-11-06 11:01:15 EST

*** This bug has been marked as a duplicate of 209639 ***
Comment 3 Jay Turner 2007-02-08 08:36:15 EST
Pulling in acks from 209639.

Note You need to log in before you can comment on or make changes to this bug.