Bug 205005 - memory passed to xeninst by xenguest-install is a string, while xeninst expects an int.
memory passed to xeninst by xenguest-install is a string, while xeninst expec...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-xeninst (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-02 00:01 EDT by Jesse Keating
Modified: 2013-01-09 21:32 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-06 00:31:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2006-09-02 00:01:23 EDT
Xen domain creation will fail due to memory not being the right size.  The logs
show that memory is always of size 0.  This is due to ParaVirtGuest.py and
possibly FullVirtGuest.py using memory * 1024 as the argument.  xenguest-install
takes memory in, and just passes it off to the correct xeninst module, but
without converting it to an int fist.  This causes the memory to be 0, string * int.
Comment 1 Jeremy Katz 2006-09-06 00:31:00 EDT
Fixed this in hg today, will be in the next build of xenguest-install

Note You need to log in before you can comment on or make changes to this bug.