Bug 205007 - compat-libstdc++-296-2.96-138 breaks aim
compat-libstdc++-296-2.96-138 breaks aim
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: compat-gcc-296 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-02 01:35 EDT by Pete Zaitcev
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-02 02:37:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2006-09-02 01:35:12 EDT
Description of problem:

It's impossible to install compat-libstdc++-296-2.96-138 without breaking
aim. Here is what happens:

[root@lembas zaitcev]# rpm -U compat-libstdc++-296-2.96-138.i386.rpm
error: Failed dependencies:
        libstdc++-libc6.1-1.so.2 is needed by (installed) aim-1.5.286-1.i386
[root@lembas zaitcev]# rpm2cpio < compat-libstdc++-296-2.96-138.i386.rpm | cpio
-it | more
508 blocks
./usr/lib/libstdc++-3-libc6.2-2-2.10.0.so
./usr/lib/libstdc++-libc6.2-2.so.3
[root@lembas zaitcev]# ldd /usr/bin/aim 
        linux-gate.so.1 =>  (0xffffe000)
        libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0x00101000)
        libgdk-1.2.so.0 => /usr/lib/libgdk-1.2.so.0 (0x00c7a000)
        libgmodule-1.2.so.0 => /usr/lib/libgmodule-1.2.so.0 (0x00b27000)
        libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x00afb000)
        libdl.so.2 => /lib/libdl.so.2 (0x009cf000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0x00d68000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x00b9b000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x009f7000)
        libXprt.so.1 => /usr/lib/libXprt.so.1 (0xb7f54000)
        libXpcs.so.1 => /usr/lib/libXpcs.so.1 (0xb7f4e000)
        libXptl.so.1 => /usr/lib/libXptl.so.1 (0xb7f4a000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00bad000)
        libm.so.6 => /lib/libm.so.6 (0x009a6000)
        libstdc++-libc6.1-1.so.2 => /usr/lib/libstdc++-libc6.1-1.so.2 (0xb7f08000)
        libc.so.6 => /lib/libc.so.6 (0x00867000)
        /lib/ld-linux.so.2 (0x0084a000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x009f2000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x009ea000)
[root@lembas zaitcev]# rpm -q compat-libstdc++-296
compat-libstdc++-296-2.96-136
[root@lembas zaitcev]# 

Version-Release number of selected component (if applicable):

compat-libstdc++-296-2.96-138

How reproducible:

Always

Steps to Reproduce:
1. Install official AOL Instant Messenger client from AIM.com
2. Run "yum update" on Rawhide
   Yum breaks when checking dependencies (thanks! could be worse!)
  
Actual results:

Updating to current Rawhide with yum is impossible, which is good.
If it were possible, aim would break.

Expected results:

Update proceeding and aim working.

Additional info:

I dunno, it may be a bug in AIM RPM to select a library by name,
or perhaps a bug in the way aim excutable was linked. But this thing
worked since RHL-9 (IIRC). Isn't the idea of compat packages
to preserve compatibility? I think something is broken here.
Comment 1 Jakub Jelinek 2006-09-02 02:37:48 EDT
The egcs 1.1.2 compatibility libstdc++ was removed on purpose, we don't
provide eternal compatibility with everything.
egcs 1.1.2 was released in March 1999 and last included in RHL 6.2.
That's a lot of years AOL had time to update their stuff to something
newer.
Comment 2 Pete Zaitcev 2006-09-02 14:00:45 EDT
OK, never mind. I thought it was a compatibility layer for gcc 2.96,
not egcs 1.1.2.

Note You need to log in before you can comment on or make changes to this bug.