This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 205027 - pirut "dependency leak"
pirut "dependency leak"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-02 12:12 EDT by drago01
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-06 00:51:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description drago01 2006-09-02 12:12:55 EDT
Description of problem:

When I mark a package to get removed using pirut it shows the packages that will
be removed because of deps, but if I cancel the transaction and unselect the app
 that has this deps it still tryes to remove the deps of this package.


Version-Release number of selected component (if applicable):
pirut-1.0.3-0.fc5

How reproducible:
always

Steps to Reproduce:
ex:
dvdstyler depends on xine
nothing depends on x86info
I have marked both to be removed (x86info and xine)
I noticed that dvdstyler will get removed
I cancel the transcation before it starts and unselect xine
pirut still wants to remove dvdstyler
if I restart pirut and only select x86info it will not try to remove dvdstyler
=> BUG
  
Actual results:
see above

Expected results:

it should not try to remove deps of apps that no longer should be removed
Comment 1 Jeremy Katz 2006-09-06 00:51:32 EDT
Fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.