Bug 205046 - Incorrect 'needs nnnM more space" messages
Incorrect 'needs nnnM more space" messages
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-02 19:36 EDT by Valdis Kletnieks
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 17:03:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2006-09-02 19:36:04 EDT
Description of problem:
yum issues "needs more space" issues for RPMs that don't go anywhere near the
filesystem in question. In this specific case, there were 56 updates being
installed, and only 1 actually touched /usr/src (which was admittedly almost
full) - but other RPMs issued messages as well.  This seems to be a
manifestation of a more general problem where yum says an RPM needs more space
when the *real* problem is "this RPM plus some unspecified list of *other* RPMs
need more space"

Version-Release number of selected component (if applicable):
yum-2.9.5-4

How reproducible:
Install a bunch of RPMs that includes 1 that will not fit on a specific
filesystem, and watch other RPMs be flagged as well.


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Lots of totally erroneous and misleading messages

Expected results:
*one* message that indicates the actual RPM that has a problem.

Additional info:
There appears to be a code confusion between "*this* RPM won't fit on the
filesystem" and "the aggregate RPMs selected won't all fit".  In the latter
case, a simple report by filesystem of additional space needed would be better
"The selected packages need the following additional space: nnnM on /, nnnM on
/usr, nnnM on /usr/share, nnnM on /usr/src".  I've noticed this same effect on
other yum runs before, where a large set of updates that included glibc would
issue lots of messages for /usr/share, but updating glibc first and then doing
everything else would work (because glibc needs some 200M free on /usr/share all
by itself).  On the other hand, if there wasn't enough space on /usr/share to
install glibc *by itself*, that's a totally different issue that can't be solved
by issuing multiple 'yum' commands to update selected components a few at a time.

Transaction Check Error:   installing package kernel-devel-2.6.17-1.2608.fc6
needs 5MB on the /usr/src filesystem
  installing package glibc-common-2.4.90-28 needs 5MB on the /usr/src filesystem
  installing package recode-3.6-22.fc6 needs 5MB on the /usr/src filesystem
  installing package SDL_mixer-1.2.7-2.fc6 needs 5MB on the /usr/src filesystem
  installing package SDL_mixer-devel-1.2.7-2.fc6 needs 5MB on the /usr/src
filesystem
  installing package xorg-x11-fonts-Type1-7.1-2 needs 5MB on the /usr/src filesystem
(and about 40 more messages)
Comment 1 Jeremy Katz 2006-09-18 17:03:50 EDT
This is the way that RPM provides the information.  There's not much else we can
do with it :( 

Note You need to log in before you can comment on or make changes to this bug.