Bug 205078 - Impossible to change default language.
Impossible to change default language.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-03 17:16 EDT by Erik P. Olsen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 03:12:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 65129 None None None Never

  None (edit)
Description Erik P. Olsen 2006-09-03 17:16:08 EDT
1. Select Tools->Options->Language Setting->Languages
2. Change under "Default languages for documents" "Western" from "English(USA)"
to "Danish" which BTW has the check mark before "Danish".
3. The check mark "For the current document only" is greyed out and cannot be
removed, so this language setting will not be for all documents as intended.

OpenOffice.org claims the bug is due to erroneous compilation because they
cannot reproduce the bug. See
<http://www.openoffice.org/issues/show_bug.cgi?id=65129>
Comment 1 Caolan McNamara 2006-09-04 03:12:09 EDT
cloph always claims "erroneous compilation" and points to the upstream "one true
rpms" for everything, despite the fact that they won't even *run* under selinux :-) 

In this case this language setting difference is deliberate, upstream rpms take
the locale as the default language, but only on the very first start of OOo,
subsequent changes to the locale don't affect OOO. Bt the fedora OOo always
takes the locale as the default language on every start so as to be consistent
with all the rest of our desktop applications. You can override it for the
current document, but it sticks to the locale, the same as practically
everything else in e.g. GNOME does.

So to change the default language that documents will be written in, change the
locale.
Comment 2 Erik P. Olsen 2006-09-04 05:32:27 EDT
Not true. My locale setting *is* Danish and still OpenOffice sticks to
English(USA). The problem comes from the fact that "For the current document
only" cannot be unchecked.

It is OK that the initial default language is the same as the locale setting but
it should be up to the individual user to chose which language he/she wants as
default for a given period. This "big brother" behaviour is typical for
Microsoft and should not be adopted by the linux community.

Note You need to log in before you can comment on or make changes to this bug.