This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 205083 - undefined symbol: NS_InitEmbedding
undefined symbol: NS_InitEmbedding
Status: CLOSED DUPLICATE of bug 201778
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-03 18:20 EDT by Andy Burns
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 14:11:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Burns 2006-09-03 18:20:55 EDT
Description of problem:

When starting eclipse, get dialog box

JVM terminated. Exit code=127
/usr/bin/java
-jar startup.jar
-os linux
-ws gtk
-arch x86
-launcher /usr/bin/eclipse
-name Eclipse
-showsplash 600
-exitdata 110014
-vm /usr/bin/java
-vmargs
-jar startup.jar 

if started from bash prompt, additionally see error messages

/usr/bin/java: symbol lookup error:
/home/andy/.eclipse/org.eclipse.platform_3.2.0/configuration/org.eclipse.osgi/bundles/249/1/.cp/libswt-mozilla-gtk-3232.so:
undefined symbol: NS_InitEmbedding

Version-Release number of selected component (if applicable):
eclipse-bugzilla.i386                    1:0.2.4-2.fc6          installed       
eclipse-cdt.i386                         1:3.1.0-2              installed       
eclipse-cdt-sdk.i386                     1:3.1.0-2              installed       
eclipse-changelog.i386                   1:2.2.3-1.fc6          installed       
eclipse-ecj.i386                         1:3.2.0-2              installed       
eclipse-jdt.i386                         1:3.2.0-2              installed       
eclipse-jdt-sdk.i386                     1:3.2.0-2              installed       
eclipse-pde.i386                         1:3.2.0-2              installed       
eclipse-pde-runtime.i386                 1:3.2.0-2              installed       
eclipse-pde-sdk.i386                     1:3.2.0-2              installed       
eclipse-platform.i386                    1:3.2.0-2              installed       
eclipse-platform-sdk.i386                1:3.2.0-2              installed       
eclipse-pydev.i386                       1:0.9.3_fc-17          installed       
eclipse-rcp.i386                         1:3.2.0-2              installed       
eclipse-rcp-sdk.i386                     1:3.2.0-2              installed       
eclipse-subclipse.i386                   1.1.5-2.fc6            installed       
eclipse-subclipse-book.i386              1.1.5-2.fc6            installed      

How reproducible:
100%
Comment 1 Ben Konrath 2006-09-04 14:11:14 EDT
This seems to be a firefox bug. As temporary work-around replace
/usr/lib/eclipse/libswt-mozilla-gtk-3232.so with this:

http://dev.eclipse.org/viewcvs/index.cgi/*checkout*/org.eclipse.swt.gtk.linux.x86/Attic/libswt-mozilla-gtk-3232.so?rev=1.2&only_with_tag=v3232m&content-type=application/octet-stream

*** This bug has been marked as a duplicate of 201778 ***

Note You need to log in before you can comment on or make changes to this bug.